enable netifd by default and add its config variable to PKG_CONFIG_DEPENDS in a few...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 14 May 2012 23:33:35 +0000 (23:33 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 14 May 2012 23:33:35 +0000 (23:33 +0000)
SVN-Revision: 31730

include/target.mk
package/6in4/Makefile
package/6to4/Makefile
package/base-files-network/Makefile
package/base-files/Makefile
package/comgt/Makefile
package/netifd/Makefile
package/ppp/Makefile
package/pptp/Makefile

index e5166fb784e6e096c3740865805f3ed84ba26a63..61ae108d547fe99f497996ef09204b7095fa2aba 100644 (file)
@@ -12,7 +12,7 @@ __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg hotplug2
+DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg hotplug2 netifd
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
 DEFAULT_PACKAGES.bootloader:=
index ee53f5e3cae5c9d25bf39194338a9fa1b633763f..c2fcc3ba1c6578af6692da3e35372fee28393780 100644 (file)
@@ -11,6 +11,8 @@ PKG_NAME:=6in4
 PKG_VERSION:=10
 PKG_RELEASE:=1
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6in4
index fc36d0f1521bf583a23594e79497bcb79fad0210..95575cf6d04c6692bf2762ecc0cfc710753167b4 100644 (file)
@@ -11,6 +11,8 @@ PKG_NAME:=6to4
 PKG_VERSION:=8
 PKG_RELEASE:=1
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6to4
index 80e78154f514f2d17d8a114d474db17cb258faac..338da396df7ae63fb2430da3c307a42235108cd4 100644 (file)
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/base-files-network
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=@!USE_NETIFD
+  DEPENDS:=@DISABLE_NETIFD
   TITLE:=Network scripts for the OpenWrt base system
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)
index 78ece51d21c636741d6a69783a6ad7d2649a1c3c..ae96ab54b82428beca110e9cd266a0695864b748 100644 (file)
@@ -35,7 +35,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+!USE_NETIFD:base-files-network +USE_NETIFD:netifd
+  DEPENDS:=+DISABLE_NETIFD:base-files-network +!DISABLE_NETIFD:netifd
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -63,8 +63,8 @@ define Package/base-files/description
 endef
 
 define Package/base-files/config
-  config USE_NETIFD
-    bool "Use netifd instead of the old network init scripts (experimental!)"
+  config DISABLE_NETIFD
+    bool "Use the old (deprecated) network init scripts instead of netifd"
        default n
 endef
 
index f2a6966e9beda44495c313beaf2c2498cc9f1a74..2839d2032ec07fdf7ea36511a5d21335cb1bff98 100644 (file)
@@ -17,8 +17,8 @@ PKG_MD5SUM:=db2452680c3d953631299e331daf49ef
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
 
-PKG_CONFIG_DEPENDS:=CONFIG_USE_NETIFD
-COMGT_VARIANT:=$(if $(CONFIG_USE_NETIFD),netifd,old)
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
+COMGT_VARIANT:=$(if $(CONFIG_PACKAGE_netifd),netifd,old)
 FILES_DIR:=./files-$(COMGT_VARIANT)
 
 include $(INCLUDE_DIR)/package.mk
index 4964d695240f93edfcf847fa8412bf7f3221d370..a5426b69ea30f6ad76b3f7c08808c78dc1634aa2 100644 (file)
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/netifd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn @USE_NETIFD
+  DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn @!DISABLE_NETIFD
   TITLE:=OpenWrt Network Interface Configuration Daemon
 endef
 
index b60ae7cb68a8ddb0b792ac4983c6987d87570200..b2be2d89ca3e2ca6dcd3ba4d38d0d8b586df86a7 100644 (file)
@@ -19,6 +19,7 @@ PKG_MD5SUM:=4621bc56167b6953ec4071043fe0ec57
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=libpcap
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
 
 PKG_INSTALL:=1
 
index 47ed07fa5c73e93deeac326f1d6617ada83e8865..c39ccb3c804a0040f5c9ff181ffaa05044af2c91 100644 (file)
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
 PKG_MD5SUM:=b47735ba5d6d37dfdbccb85afc044ede
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pptp