[package] hotplug2: make libbsd depend on "not uclibc" for now, the conditional depde...
[openwrt/svn-archive/archive.git] / package / hotplug2 / Makefile
index 9625ba27f9c1dfab07daffe9ca7092991de3f264..a003622b0858ec2c081ae39f2efa3281a5e7aef0 100644 (file)
@@ -28,7 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
-  DEPENDS:=+USE_EGLIBC:libbsd
+  DEPENDS:=+!USE_UCLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
   TARGET_LDFLAGS += -lbsd
 endif