enable netifd by default and add its config variable to PKG_CONFIG_DEPENDS in a few...
[openwrt/svn-archive/archive.git] / package / pptp / Makefile
index 081ff4e52adeb64f0f3f87a18fd067d09717f07a..c39ccb3c804a0040f5c9ff181ffaa05044af2c91 100644 (file)
@@ -1,23 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=3
+PKG_VERSION:=1.7.1
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
-PKG_CAT:=zcat
+PKG_MD5SUM:=b47735ba5d6d37dfdbccb85afc044ede
 
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,18 +23,39 @@ define Package/pptp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=PPTP client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=PPTP client
-  DESCRIPTION:=\
-       This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   URL:=http://pptpclient.sourceforge.net/
   URL:=http://pptpclient.sourceforge.net/
+  DEPENDS:=+ppp +kmod-gre +resolveip +!PACKAGE_netifd:ip
+endef
+
+define Package/pptp/description
+ This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
 endef
 
 endef
 
-define Package/pptp/install
+define Package/pptp/conffiles
+/etc/ppp/options.pptp
+endef
+
+MAKE_FLAGS += OPTIMIZE="$(TARGET_CFLAGS)"
+
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/pptp/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/netifd/proto/
+       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/netifd/proto/
+  endef
+else
+  define Package/pptp/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
-endef
+       $(INSTALL_DATA) ./files.old/pptp.sh $(1)/lib/network/
+  endef
+endif
 
 $(eval $(call BuildPackage,pptp))
 
 $(eval $(call BuildPackage,pptp))