remove the now unused Target-Kernel field from the target metadata
[openwrt/svn-archive/archive.git] / package / uboot-envtools / Makefile
index 8a3600ac8ef7e4a5f69754a17d81371dcf73576e..32574db69ee8517a26b04a4135892938a4b2e6e4 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_VERSION:=20081215
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/u/uboot-envtools/
@@ -19,16 +19,19 @@ include $(INCLUDE_DIR)/package.mk
 define Package/uboot-envtools
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=read/modify the environment for the bootloader U-Boot
+  TITLE:=read/modify U-Boot bootloader environment
+  DEPENDS:= +zlib
+  URL:=http://www.denx.de/wiki/U-Boot
 endef
 
 define Package/uboot-envtools/description
+ This package includes tools to read and modify U-Boot bootloader environment.
 endef
 
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
-       ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+       ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
 endef
 
 $(eval $(call BuildPackage,uboot-envtools))