ar71xx: add support for D-Link DIR-615 rev. Ix board
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / generic / profiles / d-link.mk
index 8fcc77f0f100c9719d0a072b15f040e598084139..f782a41d667520d51b245a2b669fed929cc80f68 100644 (file)
@@ -5,6 +5,28 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DHP1565A1
+       NAME:=D-Link DHP-1565 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/DHP1565A1/Description
+       Package set optimized for the D-Link DHP-1565 rev. A1.
+endef
+
+$(eval $(call Profile,DHP1565A1))
+
+define Profile/DIR505A1
+       NAME:=D-Link DIR-505 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR505A1/Description
+       Package set optimized for the D-Link DIR-505 rev. A1.
+endef
+
+$(eval $(call Profile,DIR505A1))
+
 define Profile/DIR600A1
        NAME:=D-Link DIR-600 rev. A1
        PACKAGES:=
@@ -27,6 +49,17 @@ endef
 
 $(eval $(call Profile,DIR601A1))
 
+define Profile/DIR601B1
+       NAME:=D-Link DIR-601 rev. B1
+       PACKAGES:=
+endef
+
+define Profile/DIR601B1/Description
+       Package set optimized for the D-Link DIR-601 rev. B1.
+endef
+
+$(eval $(call Profile,DIR601B1))
+
 define Profile/DIR615C1
        NAME:=D-Link DIR-615 rev. C1
        PACKAGES:=
@@ -38,6 +71,16 @@ endef
 
 $(eval $(call Profile,DIR615C1))
 
+define Profile/DIR615E1
+       NAME:=D-Link DIR-615 rev. E1
+       PACKAGES:=
+endef
+
+define Profile/DIR615E1/Description
+       Package set optimized for the D-Link DIR-615 rev. E1.
+endef
+
+$(eval $(call Profile,DIR615E1))
 
 define Profile/DIR615E4
        NAME:=D-Link DIR-615 rev. E4
@@ -50,16 +93,16 @@ endef
 
 $(eval $(call Profile,DIR615E4))
 
-define Profile/DIR825B1_ALL
-       NAME:=D-Link DIR-825 rev. B1 - all flavours
-       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+define Profile/DIR615IX
+       NAME:=D-Link DIR-615 rev. I1
+       PACKAGES:=
 endef
 
-define Profile/DIR825B1_ALL/Description
-    Build all D-Link DIR-825 rev. B1 images
+define Profile/DIR615IX/Description
+       Package set optimized for the D-Link DIR-615 rev. I1.
 endef
 
-$(eval $(call Profile,DIR825B1_ALL))
+$(eval $(call Profile,DIR615IX))
 
 define Profile/DIR825B1
        NAME:=D-Link DIR-825 rev. B1
@@ -68,54 +111,40 @@ endef
 
 define Profile/DIR825B1/Description
        Package set optimized for the D-Link DIR-825 rev. B1.
-       WARNING: Flashing wholeflash (openwrt optimized) image may brick your router
-       .  This will occur if your openwrt optimized image is larger than the
-       maximum size for a regular dir-825 b1 image (a little more than 6MB).
-       Please flash a TOWHOLEFLASH image instead of this image before flashing
-a 
-       WHOLEFLASH image.
 endef
 
 $(eval $(call Profile,DIR825B1))
 
-define Profile/DIR825B1_TOWHOLEFLASH
-       NAME:=D-Link DIR-825 rev. B1 designed for transition to image using whole flash
-       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+define Profile/DIR825C1
+       NAME:=D-Link DIR-825 rev. C1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
-define Profile/DIR825B1_TOWHOLEFLASH/Description
-       Package set optimized for the D-Link DIR-825 rev. B1. design for transtion to
-       image using whole flash.
-       Copies the calibration data to the last erase block so that, if desired,
-       an image optimized for use with OpenWrt (access to full flash) can be flashed.
+define Profile/DIR825C1/Description
+       Package set optimized for the D-Link DIR-825 rev. C1.
 endef
 
-$(eval $(call Profile,DIR825B1_TOWHOLEFLASH))
+$(eval $(call Profile,DIR825C1))
 
-define Profile/DIR825B1_WHOLEFLASH
-       NAME:=D-Link DIR-825 rev. B1 optimized for OpenWrt which uses full 8M flash
-       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+define Profile/DIR835A1
+       NAME:=D-Link DIR-835 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
-define Profile/DIR825B1_WHOLEFLASH/Description
-       Package set optimized for the D-Link DIR-825 rev. B1. using wholeflash
-       Can only be flashed from OpenWrt because it requires that the calibration data
-       be on the last sector of the flash (which the 'standard' version that can be flashed from
-       stock will ensure).     
+define Profile/DIR835A1/Description
+       Package set optimized for the D-Link DIR-835 rev. A1.
 endef
 
-$(eval $(call Profile,DIR825B1_WHOLEFLASH))
+$(eval $(call Profile,DIR835A1))
 
-define Profile/DIR825B1_TOSTOCK
-       NAME:=D-Link DIR-825 rev. B1 that undoes OpenWrt optimization (i.e. wholeflash)
-       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
-endef
 
-define Profile/DIR825B1_TOSTOCK/Description
-       Package set optimized for the D-Link DIR-825 rev. B1. that undoes OpenWrt optimization
-       Copies the calibration data from the last erase block to the erase block normally used
-       by the stock firmware for said data.
+define Profile/DGL5500A1
+       NAME:=D-Link DGL-5500 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ath10k
 endef
 
-$(eval $(call Profile,DIR825B1_TOSTOCK))
+define Profile/DIR5500A1/Description
+       Package set optimized for the D-Link DGL-5500 rev. A1.
+endef
 
+$(eval $(call Profile,DGL5500A1))