[uml] replace unfortify patch with a better one
[openwrt/svn-archive/archive.git] / target / linux / ramips / Makefile
index 2e04deb55d39c40ca20eb1a9b99173017b699ce0..5535199b6e45e8e9fe5f4776f99c554113d3db6b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,13 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT305x
 SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-FEATURES:=squashfs broken
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=2.6.37.6
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=kmod-leds-gpio
+DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT305x based boards.