[packages] upx: define UCL_NO_ASM to fix build on x86 (ucl is built with --disable...
[openwrt/svn-archive/archive.git] / utils / dialog / Makefile
index 802f05d2274f699c8131756394f23fbaaf4464d3..a2cecbef76cc891cda8cd6e3d22d84ed7018b26b 100644 (file)
@@ -4,20 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dialog
-PKG_VERSION:=1.0-20060221
+PKG_VERSION:=1.1-20080819
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://invisible-island.net/dialog
-PKG_MD5SUM:=acfd843163394e8bb17c841fdbe9c4a4
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=3caebd641a9f337b980becb4444336c5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,18 +22,20 @@ define Package/dialog
        CATEGORY:=Utilities
        DEPENDS:=+libncurses
        TITLE:=Dialog
-       DESCRIPTION:=\
-               A script-interpreter which provides a set of curses widgets.
        URL:=http://invisible-island.net/dialog/
 endef
 
+define Package/dialog/description
+               A script-interpreter which provides a set of curses widgets.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default)
 endef
 
 define Package/dialog/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/dialog $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dialog $(1)/usr/bin
        $(STRIP) $(1)/usr/bin/dialog
 endef