[packages] upx: define UCL_NO_ASM to fix build on x86 (ucl is built with --disable...
authorNicolas Thill <nico@openwrt.org>
Tue, 9 Mar 2010 21:23:39 +0000 (21:23 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 9 Mar 2010 21:23:39 +0000 (21:23 +0000)
SVN-Revision: 20107

utils/upx/Makefile

index 4779aa4d1dccf3e3b8dbdb992026be8eb4056c22..08377073d9c1417ea270cbafeb0f70ed336995fe 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/upx
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libucl
+  DEPENDS:=+libucl +libstdcpp +zlib
   TITLE:=The Ultimate Packer for eXecutables
   URL:=http://upx.sourceforge.net/
 endef
@@ -35,15 +35,12 @@ or other drawbacks for most of the formats supported, because of in-place
 decompression.
 endef
 
+MAKE_PATH := src
 MAKE_VARS += \
-       UPX_UCLDIR="$(STAGING_DIR)/usr/include/ucl" \
        exeext=""
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               all \
-       )
-endef
+TARGET_CPPFLAGS += \
+       -DUCL_NO_ASM \
 
 define Package/upx/install
        $(INSTALL_DIR) $(1)/usr/bin