fix lcd4linux compile error
[openwrt/svn-archive/archive.git] / utils / lcd4linux / Makefile
index 264c3856abb5ce11d8f45d4f7c40e16175a445d0..d843b3f4e91ea4172aa95e1c1da5be7402548131 100644 (file)
@@ -33,19 +33,24 @@ define Package/lcd4linux
   URL:=http://lcd4linux.bulix.org/
 endef
 
-# commas are interpreted by the $(call ...) macro, so define a intermediate variable holding our drivers spec
+# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
 PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
 
-define Build/Configure
-       $(call Build/Configure/Default, \
+CONFIGURE_ARGS += \
                --without-x \
                --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
-               --with-plugins=wireless \
-       )
-endef
+               --with-plugins=wireless
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               configure \
+               stamp-h.in \
+               config.h.in \
+       );
+       $(call Build/Configure/Default)
 endef
 
 define Package/lcd4linux/install