collectd: Work around linkage problems with conflicting librrd versions
[openwrt/svn-archive/archive.git] / utils / ntfs-3g / Makefile
index 3ef4b9cd76f6fa5f55ac9ac1f671bf3b55cfa315..df102ba4844a74f3b97387f6710632cb52671f4b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntfs-3g
-PKG_VERSION:=1.616
-PKG_RELEASE:=2
+PKG_VERSION:=1.2531
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.ntfs-3g.org/
-PKG_MD5SUM:=fdb1c55f00263c962a52d0707a6d075e
+PKG_MD5SUM:=69374cd09803c5fdbb5dabd1d704b9fe
 
 PKG_BUILD_DEPENDS:=libfuse
 
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/ntfs-3g
   TITLE:=NTFS-3G
-  DEPENDS:=+libfuse +fuse-utils
+  DEPENDS:=+libfuse +fuse-utils +libpthread
   SECTION:=utils
   CATEGORY:=Utilities
   URL:=http://www.ntfs-3g.org
@@ -36,6 +36,7 @@ endef
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --with-fuse=external \
        , \
        ac_cv_path_LDCONFIG=""