Add missing psybnc patch for proper endianess detection
authorFlorian Fainelli <florian@openwrt.org>
Thu, 13 Nov 2008 08:02:46 +0000 (08:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 13 Nov 2008 08:02:46 +0000 (08:02 +0000)
SVN-Revision: 13195

net/psybnc/patches/005-fix_endianess_detection.patch [new file with mode: 0644]

diff --git a/net/psybnc/patches/005-fix_endianess_detection.patch b/net/psybnc/patches/005-fix_endianess_detection.patch
new file mode 100644 (file)
index 0000000..7783f84
--- /dev/null
@@ -0,0 +1,31 @@
+--- a/tools/autoconf.c
++++ b/tools/autoconf.c
+@@ -222,6 +222,9 @@
+ int checkendian()
+ {
++#ifdef ENDIANESS
++    return ENDIANESS;
++#else
+     char xyz[]="\x01\x02\x03\x04";
+     unsigned long *lp;    
+     unsigned long result;
+@@ -229,6 +232,7 @@
+     result=*lp;
+     if(result==67305985) return 0x1;
+     return 0x0;
++#endif
+ }
+ int main()
+--- a/Makefile
++++ b/Makefile
+@@ -7,7 +7,7 @@
+       @$(HOSTCC) tools/convconf.c -o tools/convconf
+       @tools/convconf
+       @echo [*] Running Autoconfig.
+-      @$(HOSTCC) -I. tools/autoconf.c -o tools/autoconf
++      @$(HOSTCC) -I. -DENDIANESS=$(ENDIANESS) tools/autoconf.c -o tools/autoconf
+       @tools/autoconf
+       @echo [*] Compiling MakeSalt for Encryption..
+       @$(HOSTCC) -I. -o makesalt tools/makesalt.c