fix up downloading in python packages
authorFelix Fietkau <nbd@openwrt.org>
Wed, 24 Oct 2007 15:58:19 +0000 (15:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 24 Oct 2007 15:58:19 +0000 (15:58 +0000)
SVN-Revision: 9427

lang/egenix-mx/Makefile
lang/kid/Makefile
lang/psycopg/Makefile
lang/pyevent/Makefile
lang/pymysql/Makefile
lang/pypcap/Makefile
lang/pysqlite/Makefile
lang/twisted/Makefile
lang/yapsnmp/Makefile
utils/rdiff-backup/Makefile
utils/rrdtool/Makefile

index 2c9e0b1f1881e715939a9230e9406cf2b8d87223..3f894eef48b32b41113f61a1e432280374c25e3b 100644 (file)
@@ -21,8 +21,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-egenix-mx
index 19aa6ecc20a5be12c07903b1e5046d4c3a023d59..139cbad5eaca432bdd38ba455032c3f4fb951ee6 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-kid
index a1fdb491a251bb8d6e8abbcf0ac057cb7896d508..a1f32248fbea87dd8c6f5b33aa185067a0ff5fac 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-psycopg
index 63e1fd1b82ccbb5ab1ed4836bc38e3c669b80de4..0a48e49d0420d2898f4703ff564c488b7824beb2 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-event
index 868643bb6498c199c55f720a256e322521a66ce1..2375f6faa935361fa2e05949b7ab2bfda9cbb6b9 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-mysql
index 46adf696b143539d8da46efe220b40c78f13e177..ba7933f34292ca16171ae96e00f29bd4ef1fd3f8 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-pcap
index bade7b3237e57b5ac376d7c0a59371e4eee60d19..e9431198efad770094c5149525e1bed92d92e9be 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-sqlite
index 799e826ff93f917bb1505afcf963de32f77633cd..6cab30276aa6aa3fa3eb603f7dbcdc9c7feaed8a 100644 (file)
@@ -21,8 +21,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/twisted/default
index 851fe9f14ddbc59a34b951e392076bda2a5a33a1..8ba8149146394f87d0e957cc4fa712118a692e7f 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-yapsnmp
index 74d2c9800c84709275b1c397ee8673ab0fca9798..537ee20e1499d3524d5421c54c513d541ca8e462 100644 (file)
@@ -17,7 +17,10 @@ PKG_SOURCE_URL:=http://savannah.nongnu.org/download/rdiff-backup/
 PKG_MD5SUM:=756b38aaf2602d097cafd08996fb7887
 
 include $(INCLUDE_DIR)/package.mk
--include $(TOPDIR)/package/python/python-package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
+endif
 
 define PyPackage/rdiff-backup
   SECTION:=utils
index a376aeaa28a3f121625a78aaf3de3efb3b46f64a..25035d9d06bfbd4ea0c8736b77eea44759031791 100644 (file)
@@ -19,7 +19,10 @@ PKG_MD5SUM:=dafa161bc9c61e57636a6085c87c1fe8
 PKG_BUILD_DEPENDS:=libnotimpl python-core
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,./python-package.mk)
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
+endif
 
 define Package/rrdtool/Default
   SECTION:=utils