added fontconfig
authorJohn Crispin <john@openwrt.org>
Thu, 4 Oct 2007 19:02:48 +0000 (19:02 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 4 Oct 2007 19:02:48 +0000 (19:02 +0000)
SVN-Revision: 9126

XOrg/app/fontconfig/Makefile [new file with mode: 0644]

diff --git a/XOrg/app/fontconfig/Makefile b/XOrg/app/fontconfig/Makefile
new file mode 100644 (file)
index 0000000..13472dc
--- /dev/null
@@ -0,0 +1,59 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fontconfig
+PKG_VERSION:=2.3.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://fontconfig.org/release/
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_ARGS+=LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
+
+define Package/fontconfig
+  SECTION:=xorg-util
+  CATEGORY:=Xorg
+  SUBMENU:=font-utils
+  TITLE:=fontconfig
+  DEPENDS:=+xorg-server-essentials +libexpat 
+endef
+
+define Build/Configure
+       cd  $(PKG_BUILD_DIR)/; \
+               $(TARGET_CONFIGURE_OPTS) \
+               $(subst -fhonour-copts,,$(CONFIGURE_VARS)) \
+               $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS_XTRA) \
+                       $(CONFIGURE_ARGS) 
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) 
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/fontconfig/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/{lib,include}
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/ $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
+       $(SED)  "s,"prefix\=.*",prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/fontconfig.pc
+       $(SED)  "s,"exec_prefix\=.*",exec_prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/fontconfig.pc
+       $(SED)  "s,"libdir\=\'/usr/lib\'",libdir='$(STAGING_DIR)/usr/lib\'," $(STAGING_DIR)/usr/lib/libfontconfig.la
+endef
+
+$(eval $(call BuildPackage,fontconfig))