base-files: procd is now the init process
authorJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:53:38 +0000 (16:53 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:53:38 +0000 (16:53 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36998

package/base-files/Makefile

index 3635a564781700408f8509b5b3ca8a4ab33e461b..fa2081f8d4cb209c7a03066b1f43218a93f1e88a 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=141
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,12 +55,6 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
-define Package/base-files/config
-config PROCD_INIT
-       bool "Use procd as the init process"
-       default n
-endef
-
 ifneq ($(CONFIG_PREINITOPT),)
 define ImageConfigOptions
        mkdir -p $(1)/lib/preinit