add package PTPd
authorMatteo Croce <rootkit85@yahoo.it>
Sun, 28 Feb 2010 16:31:04 +0000 (16:31 +0000)
committerMatteo Croce <rootkit85@yahoo.it>
Sun, 28 Feb 2010 16:31:04 +0000 (16:31 +0000)
SVN-Revision: 19907

net/ptpd/Makefile [new file with mode: 0644]
net/ptpd/files/ptpd.init [new file with mode: 0644]

diff --git a/net/ptpd/Makefile b/net/ptpd/Makefile
new file mode 100644 (file)
index 0000000..19d05c2
--- /dev/null
@@ -0,0 +1,33 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ptpd
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/ptpd
+PKG_MD5SUM:=b112b2bedc7f6e6e11a838608b9e0357
+
+include $(INCLUDE_DIR)/package.mk
+
+MAKE_PATH:=src
+
+define Package/ptpd
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PTPD
+  URL:=http://ptpd.sourceforge.net/
+endef
+
+define Package/ptpd/daemon
+ The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as defined by the IEEE 1588 standard.
+ PTP was developed to provide very precise time coordination of LAN connected computers.
+endef
+
+define Package/ptpd/install
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptpd $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/ptpd.init $(1)/etc/init.d/
+endef
+
+$(eval $(call BuildPackage,ptpd))
diff --git a/net/ptpd/files/ptpd.init b/net/ptpd/files/ptpd.init
new file mode 100644 (file)
index 0000000..71b5221
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+
+START=50
+
+start() {
+       ptpd
+}
+
+stop() {
+       killall ptpd
+}