mac80211: allow to select the rt2x00-soc module for the ramips/rt3883 subtarget
authorJohn Crispin <john@openwrt.org>
Wed, 23 Apr 2014 07:52:47 +0000 (07:52 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 23 Apr 2014 07:52:47 +0000 (07:52 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 40560

package/kernel/mac80211/Makefile

index 40f08e218c85d07748825ebe6bc4e2589764cd42..bb80cfe59efaae5b42cc58eb485c209ad3633637 100644 (file)
@@ -321,7 +321,7 @@ endef
 
 define KernelPackage/rt2800-soc
 $(call KernelPackage/rt2x00/Default)
-  DEPENDS += @(TARGET_ramips_rt288x||TARGET_ramips_rt305x) +kmod-rt2800-mmio +kmod-rt2800-lib
+  DEPENDS += @(TARGET_ramips_rt288x||TARGET_ramips_rt305x||TARGET_ramips_rt3883) +kmod-rt2800-mmio +kmod-rt2800-lib
   TITLE += (RT28xx/RT3xxx SoC)
   FILES := \
        $(PKG_BUILD_DIR)/drivers/net/wireless/rt2x00/rt2x00soc.ko \