kernel: disable AFS support by default
authorFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 15:14:51 +0000 (15:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 15:14:51 +0000 (15:14 +0000)
This pulls in CONFIG_KEYS, which bloats up the kernel size and is thus
very undesirable. It also currently exposes the kernel to a local root
vulnerability

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48364

package/kernel/linux/modules/fs.mk
package/kernel/linux/modules/netsupport.mk

index 5900a4b14095e0bcfa7b811471beecd976922412..a47eea909da1712502b91411bbe9a5281d6ec8eb 100644 (file)
@@ -29,6 +29,7 @@ $(eval $(call KernelPackage,fs-fscache))
 define KernelPackage/fs-afs
   SUBMENU:=$(FS_MENU)
   TITLE:=Andrew FileSystem client
+  DEFAULT:=n
   DEPENDS:=+kmod-rxrpc +kmod-dnsresolver +kmod-fs-fscache
   KCONFIG:=\
        CONFIG_AFS_FS=m \
index e3fa9d7b5ae9d82315f82b0caa04de49eacacc57..b1cce0b2d20d1c9198428d11961878b2ad3fa474 100644 (file)
@@ -968,6 +968,7 @@ $(eval $(call KernelPackage,dnsresolver))
 define KernelPackage/rxrpc
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=AF_RXRPC support
+  HIDDEN:=1
   KCONFIG:= \
        CONFIG_AF_RXRPC \
        CONFIG_RXKAD=m \