move python packages to 'Python' submenu and make them depends on 'python'
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 18:08:06 +0000 (18:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 18:08:06 +0000 (18:08 +0000)
SVN-Revision: 8988

lang/python/Makefile
lang/python/python-package.mk

index 72d6d4038a4b01aabce7b24ccfe0445d91223946..1dcd5f24dbe972bd4f5afb60e77d20b672fdb16c 100644 (file)
@@ -26,6 +26,7 @@ PY_DISABLED_MODULES=\
        _curses _curses_panel _tkinter nis 
 
 define Package/python
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   DEPENDS:=+libexpat +libopenssl +libpthread +libreadline +uclibcxx
index c07b4654590521f68673de587099865012d9bffb..1b0d9d94065e0addfdb9001a5fa54d5a2218e55d 100644 (file)
@@ -24,10 +24,11 @@ define PyPackage
   $(eval $(call PyPackage/$(1)))
 
   define Package/$(1)
+    SUBMENU:=Python
     TITLE:=$(TITLE)
     SECTION:=lang
     CATEGORY:=Languages
-    DEPENDS:=+python
+    DEPENDS:=python
     $(call PyPackage/$(1))
   endef