add missing piece from whiterussian image building makefile to trunk/
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 18:55:48 +0000 (18:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 18:55:48 +0000 (18:55 +0000)
SVN-Revision: 2250

openwrt/target/linux/image/brcm/Makefile

index 73d236a2d527ba3d341d396abc7338d08e1c6956..31f941fc30ec24ddcba4c01f31879c190e305421 100644 (file)
@@ -25,8 +25,13 @@ endif
 ifeq ($(FS),jffs2-4MB)
 TRXALIGN:=-a 0x10000
 endif
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
-       $(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+
+$(KDIR)/loader.tmp.gz:
+       cp $(BUILD_DIR)/loader.gz $@
+       echo -ne "\\x00" >> $@
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/loader.tmp.gz
+       $(STAGING_DIR)/bin/trx -o $@ $(KDIR)/loader.tmp.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
 
 ifeq ($(KERNEL),2.6)
 FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))