Disable ssp support in openssh (#3792)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 30 Jul 2008 13:31:41 +0000 (13:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 30 Jul 2008 13:31:41 +0000 (13:31 +0000)
SVN-Revision: 12011

net/openssh/Makefile

index d0d88e5f1fec232447c1217af1c72f93d243c627..44437c44d50858217c19f47589b6bd781fd6360f 100644 (file)
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/openssh-client
   SECTION:=net
   CATEGORY:=Network
 define Package/openssh-client
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +zlib +libssp
+  DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH client
   URL:=http://www.openssh.com/
   SUBMENU:=SSH
   TITLE:=OpenSSH client
   URL:=http://www.openssh.com/
   SUBMENU:=SSH
@@ -59,7 +59,7 @@ endef
 define Package/openssh-server
   SECTION:=net
   CATEGORY:=Network
 define Package/openssh-server
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +zlib +libssp
+  DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH server
   URL:=http://www.openssh.com/
   SUBMENU:=SSH
   TITLE:=OpenSSH server
   URL:=http://www.openssh.com/
   SUBMENU:=SSH
@@ -136,6 +136,7 @@ define Build/Configure
                        --disable-utmpx \
                        --disable-wtmp \
                        --disable-wtmpx \
                        --disable-utmpx \
                        --disable-wtmp \
                        --disable-wtmpx \
+                       --without-stackprotect \
                        --without-bsd-auth \
                        --without-kerberos5 \
                        --without-pam \
                        --without-bsd-auth \
                        --without-kerberos5 \
                        --without-pam \