[package] autossh: increase reliability of connection behavior
authorFlorian Fainelli <florian@openwrt.org>
Tue, 16 Aug 2011 20:34:24 +0000 (20:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 16 Aug 2011 20:34:24 +0000 (20:34 +0000)
patch from Paul Geraedts

SVN-Revision: 28018

net/autossh/Makefile
net/autossh/files/autossh.config
net/autossh/files/autossh.init

index c207ffe3e17176e2480ff805f88faea268fc4a19..c02c12d0b3506ffaadd2c69ca035d31ba6c6d50b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autossh
 PKG_VERSION:=1.4b
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
index 2e430a0d57dfee61613460bebe89f3a827b0b1ce..6ec323858e25cb749b434a0e3338eb010cec5721 100644 (file)
@@ -1,4 +1,5 @@
 config autossh
        option ssh      '-i /etc/dropbear/id_rsa -N -T -R 2222:localhost:22 user@host'
+       option gatetime '0'
        option monitorport      '20000'
        option poll     '600'
index e873de8073b846b19cfa06896c2dfe3f01b80f7a..d91c7b7ca565da35f23589c1342f2afbfb3defdf 100644 (file)
@@ -5,10 +5,11 @@ START=80
 start_service () {
        local section="$1"
        config_get ssh "$section" ssh
+       config_get gatetime "$section" gatetime
        config_get monitorport "$section" monitorport
        config_get poll "$section" poll
 
-       AUTOSSH_POLL=${poll:-"600"} autossh -M ${monitorport:-"20000"} -f ${ssh}
+       AUTOSSH_GATETIME=${gatetime:-"30"} AUTOSSH_POLL=${poll:-"600"} autossh -M ${monitorport:-"20000"} -f ${ssh}
 }
 
 boot() {