remove uneeded install step, move description to a separate def, cleanup
authorNicolas Thill <nico@openwrt.org>
Thu, 6 Sep 2007 02:39:41 +0000 (02:39 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 6 Sep 2007 02:39:41 +0000 (02:39 +0000)
SVN-Revision: 8638

admin/htop/Makefile

index 1b0d6894d60ddf394a8ac0fc3a67cb27ae1c013d..3c90dfe864e83cb7125582f7b290bf708802b117 100644 (file)
@@ -11,14 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=htop
 PKG_VERSION:=0.6.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=180aa7c9db7106ed1197b1e408660a0e
 
-PKG_SOURCE_URL:=@SF/htop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/htop
+PKG_MD5SUM:=180aa7c9db7106ed1197b1e408660a0e
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,22 +23,20 @@ define Package/htop
   CATEGORY:=Administration
   TITLE:=process viewer
   DEPENDS:=+libncurses
-  DESCRIPTION:=\
-       An interactive process viewer with colors \\\
-       tree mode and other features.
   URL:=http://htop.sourceforge.net/
 endef
 
+define Package/htop/description
+ An interactive process viewer with colors tree mode and other features.
+endef
+
 define Build/Compile
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) all
 endef
 
 define Package/htop/install    
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,htop))