[uClibc] more cygwin build fixes
authorFlorian Fainelli <florian@openwrt.org>
Wed, 26 Aug 2009 07:25:24 +0000 (07:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 26 Aug 2009 07:25:24 +0000 (07:25 +0000)
SVN-Revision: 17401

toolchain/uClibc/Makefile
toolchain/uClibc/patches-0.9.30.1/160-unifdef_fix.patch

index 42ff5abf4a1883861609288f2116987c5d2542f3..1b8723f6781335b357aab1f00de6e97d837e00bf 100644 (file)
@@ -74,7 +74,7 @@ define Host/Prepare
                -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
                $(HOST_BUILD_DIR)/.config
        $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"
                -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
                $(HOST_BUILD_DIR)/.config
        $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"
-       PATH=$(TARGET_PATH) $(MAKE) -C $(HOST_BUILD_DIR) \
+       PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
                PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
                DEVEL_PREFIX=/usr/ \
                RUNTIME_PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
                PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
                DEVEL_PREFIX=/usr/ \
                RUNTIME_PREFIX="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/" \
@@ -88,7 +88,7 @@ endef
 define Host/Configure
 endef
 
 define Host/Configure
 endef
 
-UCLIBC_MAKE = PATH=$(TARGET_PATH) $(MAKE) -C $(HOST_BUILD_DIR) \
+UCLIBC_MAKE = PATH='$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
        $(TARGET_CONFIGURE_OPTS) \
        DEVEL_PREFIX=/usr/ \
        RUNTIME_PREFIX=/ \
        $(TARGET_CONFIGURE_OPTS) \
        DEVEL_PREFIX=/usr/ \
        RUNTIME_PREFIX=/ \
index 2b290607a7ec86ad6da2d0ba04f5fe419cd1d9fa..6c7b221c36d4eb2528f8fbb45e16ebc186abbc3a 100644 (file)
@@ -1,29 +1,43 @@
---- a/extra/scripts/unifdef.c
-+++ b/extra/scripts/unifdef.c
-@@ -206,7 +206,7 @@ static void             done(void);
+Index: uClibc-0.9.30.1/extra/scripts/unifdef.c
+===================================================================
+--- uClibc-0.9.30.1.orig/extra/scripts/unifdef.c       2008-04-28 01:10:00.000000000 +0200
++++ uClibc-0.9.30.1/extra/scripts/unifdef.c    2009-08-25 15:20:08.000000000 +0200
+@@ -206,7 +206,11 @@
  static void             error(const char *);
  static int              findsym(const char *);
  static void             flushline(bool);
 -static Linetype         getline(void);
  static void             error(const char *);
  static int              findsym(const char *);
  static void             flushline(bool);
 -static Linetype         getline(void);
++#ifndef __CYGWIN__
 +static Linetype         __getline(void);
 +static Linetype         __getline(void);
++#else
++static Linetype               get_line(void);
++#endif
  static Linetype         ifeval(const char **);
  static void             ignoreoff(void);
  static void             ignoreon(void);
  static Linetype         ifeval(const char **);
  static void             ignoreoff(void);
  static void             ignoreon(void);
-@@ -512,7 +512,7 @@ process(void)
+@@ -512,7 +516,11 @@
  
        for (;;) {
                linenum++;
 -              lineval = getline();
  
        for (;;) {
                linenum++;
 -              lineval = getline();
++#ifndef __CYGWIN__
 +              lineval = __getline();
 +              lineval = __getline();
++#else
++              lineval = get_line();
++#endif
                trans_table[ifstate[depth]][lineval]();
                debug("process %s -> %s depth %d",
                    linetype_name[lineval],
                trans_table[ifstate[depth]][lineval]();
                debug("process %s -> %s depth %d",
                    linetype_name[lineval],
-@@ -526,7 +526,7 @@ process(void)
+@@ -526,7 +534,11 @@
   * help from skipcomment().
   */
  static Linetype
 -getline(void)
   * help from skipcomment().
   */
  static Linetype
 -getline(void)
++#ifndef __CYGWIN__
 +__getline(void)
 +__getline(void)
++#else
++get_line(void)
++#endif
  {
        const char *cp;
        int cursym;
  {
        const char *cp;
        int cursym;