install bluez.pc pkg-config file (closes: #2238)
authorNicolas Thill <nico@openwrt.org>
Mon, 20 Aug 2007 08:33:10 +0000 (08:33 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 20 Aug 2007 08:33:10 +0000 (08:33 +0000)
SVN-Revision: 8440

libs/bluez-libs/Makefile

index b3ac9290df6bdc53d808e02265ca23df2ea2a5e3..516c21291d6017c4f302953ba65e7078d338e1bc 100644 (file)
@@ -47,12 +47,17 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/bluetooth/*.h $(STAGING_DIR)/usr/include/bluetooth
        mkdir -p $(STAGING_DIR)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbluetooth.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/bluez.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(SED) 's,-I$$$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/bluez.pc
+       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/bluez.pc
 endef
 
 define Build/UninstallDev
        rm -rf \
                $(STAGING_DIR)/usr/include/bluetooth \
-               $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
+               $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*} \
+               $(STAGING_DIR)/usr/lib/pkgconfig/bluez.pc
 endef
 
 define Package/bluez-libs/install