Fix glib2 compilation errors when no glib2-dev package is installed on the host syste...
authorFlorian Fainelli <florian@openwrt.org>
Sun, 13 May 2007 09:03:59 +0000 (09:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 13 May 2007 09:03:59 +0000 (09:03 +0000)
SVN-Revision: 7198

libs/glib2/Makefile
libs/glib2/patches/001-no_glib_marshal.patch [new file with mode: 0644]

index 5653b3c51f49a6f61b35da23e080f141c0335a25..4f0efda947a1d2423a4848e1e119f6536116840b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -45,31 +45,24 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/glib \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
+               all install
 endef
 
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(STAGING_DIR)/usr/bin/
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/glib-2.0 $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/glib-2.0 $(STAGING_DIR)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libg* $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/g*-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
 endef
 
 define Build/UninstallDev
        rm -rf \
-               $(STAGING_DIR)/usr/bin/{glib-genmarshal,glib-gettextize,glib-mkenums.gobject-query} \
                $(STAGING_DIR)/usr/include/glib-2.0 \
-               $(STAGING_DIR)/usr/lib/{glib,libg*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/g*-2.0.pc 
+               $(STAGING_DIR)/usr/lib/libg*
 endef
 
 define Package/glib2/install   
diff --git a/libs/glib2/patches/001-no_glib_marshal.patch b/libs/glib2/patches/001-no_glib_marshal.patch
new file mode 100644 (file)
index 0000000..984a8e8
--- /dev/null
@@ -0,0 +1,13 @@
+diff -urN glib-2.12.12/configure glib-2.12.12.new/configure
+--- glib-2.12.12/configure     2007-05-02 01:20:31.000000000 +0200
++++ glib-2.12.12.new/configure 2007-05-11 09:24:21.000000000 +0200
+@@ -43081,8 +43081,7 @@
+   if test x$GLIB_GENMARSHAL = xno; then
+     { { echo "$as_me:$LINENO: error: Could not find a glib-genmarshal in your PATH" >&5
+-echo "$as_me: error: Could not find a glib-genmarshal in your PATH" >&2;}
+-   { (exit 1); exit 1; }; }
++echo "$as_me: error: Could not find a glib-genmarshal in your PATH" >&2;} }
+   fi
+ fi