[package] updpate syslog-ng3 to 3.0.5, add support for logging kernel messages, patch...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 20 Mar 2010 10:29:33 +0000 (10:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 20 Mar 2010 10:29:33 +0000 (10:29 +0000)
SVN-Revision: 20314

admin/syslog-ng3/Makefile
admin/syslog-ng3/files/syslog-ng.conf

index 2ad3d7254249e4c90fe6ae61fe41c8d9f2b223e2..a6192291df6464f6b42df81af119b8bedb0379f3 100644 (file)
@@ -8,12 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=syslog-ng
-PKG_VERSION:=3.0.4
+PKG_VERSION:=3.0.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=86c39779261545d2289e9c309e262b8d
+PKG_MD5SUM:=28f0d9ff2243b330e8cd6311ef9b2f12
 
-PKG_SOURCE_URL:= \
-       http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.0.4/source/
+PKG_SOURCE_URL:=http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/$(PKG_VERSION)/source/
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 
 include $(INCLUDE_DIR)/package.mk
index 919bbc89dddb39f117376d0f2dd381ade92f7e7d..972848c644048a7a6cfeefda69ac65a22b56cb39 100644 (file)
@@ -21,6 +21,10 @@ source net {
        udp(ip(0.0.0.0) port(514));
 };
 
+source kernel {
+        file("/proc/kmsg" program_override("kernel"));
+};
+
 destination messages {
        file("/var/log/messages");
 };
@@ -28,5 +32,6 @@ destination messages {
 log {
        source(src);
        source(net);
+        source(kernel);
        destination(messages);
 };