[package] update fowsr to 20100718
authorFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 11:39:06 +0000 (11:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 11:39:06 +0000 (11:39 +0000)
changed name of cache file to '/var/fowsr.dat'
- added CWS_print_decoded_data() method
- added debug print outs as command line options
- added patch for checking valid fixed block data (thanks Timo Koivunen!)
 - added XML-format output file
- added pywws format table
- added CWS_write_byte() method
- added CWS_write_block() method
- added ws format definitions for unit settings
- added ws format definitions for unit display settings
 - added ws format definitions for unit alarm settings

Signed-off-by: Arne-Jørgen Auberg arne.jorgen.auberg@gmail.com
SVN-Revision: 22428

utils/fowsr/Makefile

index 703f16b18db1235b0a98e569603d28ac0e651290..2de6499b9cc4d7d8a21b4f78e6705b9ae33c41b0 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fowsr
 PKG_VERSION:=1.0
-PKG_RELEASE:=20100501
+PKG_RELEASE:=20100718
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.gz
 PKG_SOURCE_URL:=http://fowsr.googlecode.com/files
-PKG_MD5SUM:=aab66ea115fb304e0f5a6171dd6df2ba
+PKG_MD5SUM:=34a53f0ba60a62636feef3e09d9e4312
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,11 +28,7 @@ endef
 define Package/fowsr/description
   fowsr is a USB Data Collector application for WH1080 compatible
   weather stations.
-  Output formats includes Wunderground.com and pywws.
-  See http://www.foshk.com for details and download of the
-  EasyWeather application.
-  All weather stations that can use the EasyWeather application
-  will work with this software.
+  Output formats includes XML, Wunderground.com and pywws.
 endef
 
 CONFIGURE_ARGS += \
@@ -41,6 +37,9 @@ CONFIGURE_ARGS += \
 define Package/fowsr/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fowsr $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wunderground.sh $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pywws.sh $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/xml.sh $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fowsr))