[adm5120] generate firmware images for the CAS-700/771/790/861 devices
authorGabor Juhos <juhosg@openwrt.org>
Mon, 14 Jan 2008 16:14:53 +0000 (16:14 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 14 Jan 2008 16:14:53 +0000 (16:14 +0000)
SVN-Revision: 10193

target/linux/adm5120/image/router_le.mk
target/linux/adm5120/router_le/profiles/Cellvision.mk

index 3053d2d8b66243d8e0175078e6d71447b44b1500..4d91dbf014aca5bd648d683d3418b664e461880f 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -50,6 +50,16 @@ define Image/Build/Infineon
        cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2)).img
 endef
 
        cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2)).img
 endef
 
+define Image/Build/Cellvision2
+       # only for CAS-700/771/790/861
+       $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
+       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       dd if=$(KDIR)/loader-$(2).gz of=$(call imgname,$(1),$(2)).bin bs=64k conv=sync
+       cat $(call imgname,$(1),$(2)).trx >> $(call imgname,$(1),$(2)).bin
+       echo -ne '\x14\x07\x24\x06$(2)' | dd bs=14 count=1 conv=sync >> $(call imgname,$(1),$(2)).bin
+       echo -ne 'OpenWrt\x00\x00\x00' >> $(call imgname,$(1),$(2)).bin
+endef
+
 define Image/Build/MyLoader
        $(call Image/Build/Loader,$(2),gz,0x80500000,0)
        $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
 define Image/Build/MyLoader
        $(call Image/Build/Loader,$(2),gz,0x80500000,0)
        $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
@@ -61,9 +71,59 @@ define Image/Build/MyLoader
                $(call imgname,$(1),$(2)).bin
 endef
 
                $(call imgname,$(1),$(2)).bin
 endef
 
+#
+# Cellvision CAS-700
+#
+define Image/Build/Board/CAS700
+       $(call Image/Build/Cellvision2,$(1),cas-700)
+endef
+
+define Image/Build/Board/CAS700/squashfs
+       $(call Image/Build/Board/CAS700,squashfs)
+endef
+
+define Image/Build/Board/CAS700/jffs2-64k
+       $(call Image/Build/Board/CAS700,jffs2-64k)
+endef
+
+define Image/Build/Board/CAS700/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-700,gz)
+endef
+
+#
+# Cellvision CAS-700W
+#
+define Image/Build/Board/CAS700W
+       $(call Image/Build/Cellvision2,$(1),cas-700w)
+endef
+
+define Image/Build/Board/CAS700W/squashfs
+       $(call Image/Build/Board/CAS700W,squashfs)
+endef
+
+define Image/Build/Board/CAS700W/jffs2-64k
+       $(call Image/Build/Board/CAS700W,jffs2-64k)
+endef
+
+define Image/Build/Board/CAS700W/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-700w,gz)
+endef
+
 #
 # Cellvision CAS-771
 #
 #
 # Cellvision CAS-771
 #
+define Image/Build/Board/CAS771
+       $(call Image/Build/Cellvision2,$(1),cas-771)
+endef
+
+define Image/Build/Board/CAS771/squashfs
+       $(call Image/Build/Board/CAS771,squashfs)
+endef
+
+define Image/Build/Board/CAS771/jffs2-64k
+       $(call Image/Build/Board/CAS771,jffs2-64k)
+endef
+
 define Image/Build/Board/CAS771/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
 endef
 define Image/Build/Board/CAS771/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
 endef
@@ -71,10 +131,79 @@ endef
 #
 # Cellvision CAS-771W
 #
 #
 # Cellvision CAS-771W
 #
+define Image/Build/Board/CAS771W
+       $(call Image/Build/Cellvision2,$(1),cas-771w)
+endef
+
+define Image/Build/Board/CAS771W/squashfs
+       $(call Image/Build/Board/CAS771W,squashfs)
+endef
+
+define Image/Build/Board/CAS771W/jffs2-64k
+       $(call Image/Build/Board/CAS771W,jffs2-64k)
+endef
+
 define Image/Build/Board/CAS771W/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,cas-771w,gz)
 endef
 
 define Image/Build/Board/CAS771W/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,cas-771w,gz)
 endef
 
+#
+# Cellvision CAS-790
+#
+define Image/Build/Board/CAS790
+       $(call Image/Build/Cellvision2,$(1),cas-790)
+endef
+
+define Image/Build/Board/CAS790/squashfs
+       $(call Image/Build/Board/CAS790,squashfs)
+endef
+
+define Image/Build/Board/CAS790/jffs2-64k
+       $(call Image/Build/Board/CAS790,jffs2-64k)
+endef
+
+define Image/Build/Board/CAS790/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-790,gz)
+endef
+
+#
+# Cellvision CAS-861
+#
+define Image/Build/Board/CAS861
+       $(call Image/Build/Cellvision2,$(1),cas-861)
+endef
+
+define Image/Build/Board/CAS861/squashfs
+       $(call Image/Build/Board/CAS861,squashfs)
+endef
+
+define Image/Build/Board/CAS861/jffs2-64k
+       $(call Image/Build/Board/CAS861,jffs2-64k)
+endef
+
+define Image/Build/Board/CAS861/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-861,gz)
+endef
+
+#
+# Cellvision CAS-861W
+#
+define Image/Build/Board/CAS861W
+       $(call Image/Build/Cellvision2,$(1),cas-861w)
+endef
+
+define Image/Build/Board/CAS861W/squashfs
+       $(call Image/Build/Board/CAS861W,squashfs)
+endef
+
+define Image/Build/Board/CAS861W/jffs2-64k
+       $(call Image/Build/Board/CAS861W,jffs2-64k)
+endef
+
+define Image/Build/Board/CAS861W/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,cas-861w,gz)
+endef
+
 #
 # Compex NP27G
 #
 #
 # Compex NP27G
 #
@@ -298,8 +427,13 @@ endef
 # Groups
 #
 define Image/Build/Group/Cellvision
 # Groups
 #
 define Image/Build/Group/Cellvision
+       $(call Image/Build/Board/CAS700/$(1))
+       $(call Image/Build/Board/CAS700W/$(1))
        $(call Image/Build/Board/CAS771/$(1))
        $(call Image/Build/Board/CAS771W/$(1))
        $(call Image/Build/Board/CAS771/$(1))
        $(call Image/Build/Board/CAS771W/$(1))
+       $(call Image/Build/Board/CAS790/$(1))
+       $(call Image/Build/Board/CAS861/$(1))
+       $(call Image/Build/Board/CAS861W/$(1))
 endef
 
 define Image/Build/Group/WP54G
 endef
 
 define Image/Build/Group/WP54G
@@ -371,6 +505,14 @@ define Image/Build/Profile/NP28G
        $(call Image/Build/Board/NP28G/$(1))
 endef
 
        $(call Image/Build/Board/NP28G/$(1))
 endef
 
+define Image/Build/Profile/CAS700
+       $(call Image/Build/Board/CAS700/$(1))
+endef
+
+define Image/Build/Profile/CAS700W
+       $(call Image/Build/Board/CAS700W/$(1))
+endef
+
 define Image/Build/Profile/CAS771
        $(call Image/Build/Board/CAS771/$(1))
 endef
 define Image/Build/Profile/CAS771
        $(call Image/Build/Board/CAS771/$(1))
 endef
@@ -379,6 +521,18 @@ define Image/Build/Profile/CAS771W
        $(call Image/Build/Board/CAS771W/$(1))
 endef
 
        $(call Image/Build/Board/CAS771W/$(1))
 endef
 
+define Image/Build/Profile/CAS790
+       $(call Image/Build/Board/CAS790/$(1))
+endef
+
+define Image/Build/Profile/CAS861
+       $(call Image/Build/Board/CAS861/$(1))
+endef
+
+define Image/Build/Profile/CAS861W
+       $(call Image/Build/Board/CAS861W/$(1))
+endef
+
 define Image/Build/Profile/BR6104K
        $(call Image/Build/Board/BR6104K/$(1))
 endef
 define Image/Build/Profile/BR6104K
        $(call Image/Build/Board/BR6104K/$(1))
 endef
index 44656ffe996443f5ea3249fe5a32b72bc2c89e39..218c2b5079854fd098b604c17f7349b011838da2 100644 (file)
@@ -1,12 +1,30 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
+define Profile/CAS700
+       NAME:=Cellvision CAS-700 IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS700/Description
+       Package set optimized for the Cellvision CAS-700 device.
+endef
+
+define Profile/CAS700W
+       NAME:=Cellvision CAS-700W IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS700W/Description
+       Package set optimized for the Cellvision CAS-700W device.
+endef
+
 define Profile/CAS771
 define Profile/CAS771
-       NAME:=Cellvision CAS-771 IP camera
+       NAME:=Cellvision CAS-771 IP camera (Untested)
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
@@ -15,7 +33,7 @@ define Profile/CAS771/Description
 endef
 
 define Profile/CAS771W
 endef
 
 define Profile/CAS771W
-       NAME:=Cellvision CAS-771W IP camera
+       NAME:=Cellvision CAS-771W IP camera (Untested)
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
@@ -23,5 +41,37 @@ define Profile/CAS771W/Description
        Package set optimized for the Cellvision CAS-771W device.
 endef
 
        Package set optimized for the Cellvision CAS-771W device.
 endef
 
+define Profile/CAS790
+       NAME:=Cellvision CAS-790 IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS790/Description
+       Package set optimized for the Cellvision CAS-790 device.
+endef
+
+define Profile/CAS861
+       NAME:=Cellvision CAS-861 IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS861/Description
+       Package set optimized for the Cellvision CAS-861 device.
+endef
+
+define Profile/CAS861W
+       NAME:=Cellvision CAS-861W IP camera (Untested)
+       PACKAGES:=kmod-rt2500
+endef
+
+define Profile/CAS861W/Description
+       Package set optimized for the Cellvision CAS-861W device.
+endef
+
+$(eval $(call Profile,CAS700))
+$(eval $(call Profile,CAS700W))
 $(eval $(call Profile,CAS771))
 $(eval $(call Profile,CAS771W))
 $(eval $(call Profile,CAS771))
 $(eval $(call Profile,CAS771W))
+$(eval $(call Profile,CAS790))
+$(eval $(call Profile,CAS861))
+$(eval $(call Profile,CAS861W))