clean up the syslog-ng3 package and make it compile
authorFelix Fietkau <nbd@openwrt.org>
Thu, 3 Sep 2009 01:51:59 +0000 (01:51 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 3 Sep 2009 01:51:59 +0000 (01:51 +0000)
SVN-Revision: 17501

admin/syslog-ng3/Makefile

index dcb92d808c37881e8f041ae4312fe8fe349867a7..25fec836d4f4f0eba96fe8ce663464afab876e39 100644 (file)
@@ -37,17 +37,25 @@ define Package/syslog-ng3/conffiles
 endef
 
 define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-dependency-tracking \
-               --enable-tcp-wrapper \
-               --disable-glibtest \
-               , \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include/eventlog $(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
-               PKG_CONFIG="$(STAGING_DIR_HOST)/bin/pkg-config" \
-       )
+       $(SED) 's,-I/usr/include,,' $(PKG_BUILD_DIR)/configure
+       $(Build/Configure/Default)
 endef
 
+CONFIGURE_ARGS +=  \
+       --disable-dependency-tracking \
+       --enable-tcp-wrapper \
+       --disable-glibtest
+
+TARGET_CPPFLAGS += \
+       -I$(STAGING_DIR)/usr/include/eventlog
+
+TARGET_LDFLAGS += \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+CONFIGURE_VARS += \
+       LIBDBI_CFLAGS="-I$(STAGING_DIR)/usr/include"
+
 define Package/syslog-ng3/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/syslog-ng $(1)/usr/sbin/