[package] base-files: retrigger usb coldplug after module loading, solves usb_modeswi...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 May 2011 10:25:58 +0000 (10:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 May 2011 10:25:58 +0000 (10:25 +0000)
SVN-Revision: 26848

package/base-files/Makefile
package/base-files/files/etc/init.d/boot

index 95ab5a7c17f290a8c27981ef35ab7ca62d63213c..c10f4832707759180c91e1fcbc4573311863616d 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=68
+PKG_RELEASE:=69
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index c3019df04ecdbf7251de195a53b9b54f2292248a..357ae3f31d468d2e500741959f82d4d595999443 100755 (executable)
@@ -80,6 +80,11 @@ start() {
        }
 
        load_modules /etc/modules.d/*
+
+       # another round of USB coldplugging to kick devices into operation which lacked drivers before
+       for dev in /sys/bus/usb/devices/*/uevent; do
+               [ -e "$dev" ] && echo -n add > "$dev"
+       done
 }
 
 stop() {