[packages] gnuplot: update to 4.4.4, add missing dependencies & copyright, disable...
authorStephen Walker <stephendwalker@gmail.com>
Sat, 14 Jan 2012 02:01:04 +0000 (02:01 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sat, 14 Jan 2012 02:01:04 +0000 (02:01 +0000)
SVN-Revision: 29741

utils/gnuplot/Makefile
utils/gnuplot/patches/010-Makefile.in.patch

index b60e943b6de3a02e5878f3472e07a5e756ec94cc..80cc80f7772ba76fe76c13cd492f1d67bc99a490 100644 (file)
@@ -1,14 +1,21 @@
+#
+# Copyright (C) 2010-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnuplot
-PKG_VERSION:=4.4.0
-PKG_RELEASE:=2
+PKG_VERSION:=4.4.4
+PKG_RELEASE:=1
 
-PKG_INSTALL=1
+PKG_INSTALL:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/gnuplot
-PKG_MD5SUM:=e708665bd512153ad5c35252fe499059
+PKG_MD5SUM:=97a43328e81e57ebed7f135ca0c07e82
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
@@ -24,13 +31,14 @@ CONFIGURE_VARS += \
 define Package/gnuplot
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libncurses +uclibcxx +zlib +libpng +libfreetype +libgd $(INTL_DEPENDS) $(ICONV_DEPENDS)
+  DEPENDS:=+libncurses +uclibcxx +zlib +libpng +libfreetype +libgd \
+       $(INTL_DEPENDS) $(ICONV_DEPENDS) +libpthread +libreadline
   TITLE:=A portable command-line driven graphing utility
   URL:=http://sourceforge.net/projects/gnuplot/
 endef
 
 define Package/gnuplot/description
-  Gnuplot  is a portable command-line driven graphing utility for linux, OS/2, 
+  Gnuplot is a portable command-line driven graphing utility for linux, OS/2,
   MS Windows, OSX, VMS, and many other platforms.
 endef
 
@@ -40,7 +48,8 @@ CONFIGURE_ARGS += \
        --without-tutorial \
        --without-row-help \
        --without-lisp-files \
-       --disable-wxwidgets
+       --disable-wxwidgets \
+       --without-lua
 
 define Package/gnuplot/install
        $(INSTALL_DIR) $(1)/usr/bin
index a2e76b3618603f969e1de4ae2cf0faa8c185113e..ddf921ab581ef717d22b2f03a4dd1123262cf644 100644 (file)
@@ -1,6 +1,6 @@
---- a/Makefile.in.orig 2010-03-13 22:20:04.000000000 +0100
-+++ b/Makefile.in      2010-06-03 15:08:35.000000000 +0200
-@@ -240,7 +240,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -240,7 +240,7 @@ top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  AUTOMAKE_OPTIONS = foreign 1.2h