cns3xxx: fix building initramfs and non-initramfs together
authorFelix Fietkau <nbd@openwrt.org>
Fri, 1 Aug 2014 07:10:00 +0000 (07:10 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 1 Aug 2014 07:10:00 +0000 (07:10 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41922

target/linux/cns3xxx/image/Makefile

index ad3789adf4855d4e0dcfc129ca56d2566e70fe41..c86b642e6c116fde565a83a6a42e8eb17db27ec0 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage
+       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
 endef
 
 # Build sysupgrade image