make uclibc a bit smaller
authorFelix Fietkau <nbd@openwrt.org>
Fri, 21 Oct 2005 23:39:26 +0000 (23:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 21 Oct 2005 23:39:26 +0000 (23:39 +0000)
SVN-Revision: 2219

openwrt/toolchain/uClibc/files/config.i386
openwrt/toolchain/uClibc/files/config.mipsel
openwrt/toolchain/uClibc/patches/120-more_standard_math.patch [new file with mode: 0644]

index c76d946f112105bd6780f73326e86d7cd3708330..b1a9ec3a1c424402b70fbf5c6e431f38144aa636 100644 (file)
@@ -57,7 +57,7 @@ ARCH_LITTLE_ENDIAN=y
 ARCH_HAS_MMU=y
 UCLIBC_HAS_FLOATS=y
 HAS_FPU=y
-DO_C99_MATH=y
+# DO_C99_MATH is not set
 KERNEL_SOURCE="./toolchain_build_i386/linux"
 C_SYMBOL_PREFIX=""
 HAVE_DOT_CONFIG=y
index 8c94447789cd148f4c993b3f1b4fe0b733e50e0b..0c756b5f5d6031986a967819bf532ae3ab11c49d 100644 (file)
@@ -42,7 +42,7 @@ ARCH_LITTLE_ENDIAN=y
 ARCH_HAS_MMU=y
 UCLIBC_HAS_FLOATS=y
 HAS_FPU=y
-DO_C99_MATH=y
+# DO_C99_MATH is not set
 KERNEL_SOURCE="./toolchain_build_mipsel/linux"
 C_SYMBOL_PREFIX=""
 HAVE_DOT_CONFIG=y
diff --git a/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch b/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch
new file mode 100644 (file)
index 0000000..f7d626a
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN uClibc.old/libm/Makefile uClibc.dev/libm/Makefile
+--- uClibc.old/libm/Makefile   2005-08-18 00:49:41.000000000 +0200
++++ uClibc.dev/libm/Makefile   2005-10-22 00:56:03.106683500 +0200
+@@ -81,6 +81,8 @@
+        w_cosh.c w_exp.c s_fabs.c s_floor.c w_fmod.c s_frexp.c \
+        s_ldexp.c w_log.c w_log10.c s_modf.c w_pow.c s_sin.c \
+        w_sinh.c w_sqrt.c s_tan.c s_tanh.c
++# extra stuff required for some apps
++CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c
+ CSRC+=   s_expm1.c s_scalbn.c s_copysign.c e_acos.c e_asin.c e_atan2.c \
+        k_cos.c e_cosh.c e_exp.c e_fmod.c e_log.c e_log10.c e_pow.c \
+        k_sin.c e_sinh.c e_sqrt.c k_tan.c e_rem_pio2.c k_rem_pio2.c \