[package] compile lvm2 with fpic when necessary (#6930)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 25 Mar 2010 13:44:13 +0000 (13:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 25 Mar 2010 13:44:13 +0000 (13:44 +0000)
SVN-Revision: 20423

utils/lvm2/Makefile

index 3eacf301d9350c2dbb6bacec2272a9635ffd2069..572e38e516a07c507c74fd2f2740cdd883b698f4 100644 (file)
@@ -84,7 +84,7 @@ CONFIGURE_ARGS += --disable-o_direct
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
 endef