pwrtray: Add fix backend-only compile
authorMichael Büsch <mb@bu3sch.de>
Sat, 2 Oct 2010 17:10:12 +0000 (17:10 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 2 Oct 2010 17:10:12 +0000 (17:10 +0000)
SVN-Revision: 23182

Xorg/app/pwrtray/Makefile

index 804464aac44f3b81fa1751638a2fa1c52c08c6e3..eca2c5be660ee725393b4ccea08ce8968c3c14e6 100644 (file)
@@ -76,7 +76,7 @@ define Package/pwrtray-backend/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray-backend $(1)/usr/bin/
        $(if $(CONFIG_PACKAGE_libX11),$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray-xlock $(1)/usr/bin/)
        $(if $(CONFIG_PACKAGE_pwrtray),$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray $(1)/usr/bin/)
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/pwrtray $(1)/usr/share/
+       $(if $(CONFIG_PACKAGE_pwrtray),$(CP) $(PKG_INSTALL_DIR)/usr/share/pwrtray $(1)/usr/share/)
        [ -e $(1)/etc/pwrtray-backendrc ] || \
                $(INSTALL_DATA) ./files/etc/pwrtray-backendrc $(1)/etc/
 endef