Convert ttcp to new packaging style, add PKG_VERSION, use TARGET_CFLAGS
authorNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 23:08:46 +0000 (23:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 23:08:46 +0000 (23:08 +0000)
SVN-Revision: 982

openwrt/package/ttcp/Makefile
openwrt/package/ttcp/ipkg/ttcp.control [new file with mode: 0644]
openwrt/package/ttcp/ttcp.control [deleted file]

index ec91ef73586c4434fd453bbc102eee1a506ba516..080aa86f0c0ad2ed4fefca836a3ce7f9791d3ffa 100644 (file)
@@ -3,29 +3,28 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ttcp
+PKG_VERSION:=3.8
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/ttcp
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_RELEASE)_$(ARCH).ipk
 
-$(PKG_BUILD_DIR)/usr/bin/ttcp:
-       mkdir -p $(PKG_BUILD_DIR)/usr/bin
-       $(TARGET_CC) -o $@ ttcp.c
-       $(STRIP) $@
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/usr/bin/ttcp
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_RELEASE) $(ARCH)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+$(eval $(call PKG_template,TTCP,ttcp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list:
-       $(IPKG) install $(PKG_IPK)
+$(PKG_BUILD_DIR)/.prepared:
+       mkdir -p $@
+       touch $@
 
-source:
-prepare:
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
 
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/ttcp ttcp.c
+       touch $@
+
+$(IPKG_TTCP):
+       install -d -m0755 $(IDIR_TTCP)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/ttcp $(IDIR_TTCP)/usr/bin/
+       $(RSTRIP) $(IDIR_TTCP)
+       $(IPKG_BUILD) $(IDIR_TTCP) $(PACKAGE_DIR)
diff --git a/openwrt/package/ttcp/ipkg/ttcp.control b/openwrt/package/ttcp/ipkg/ttcp.control
new file mode 100644 (file)
index 0000000..3633ef1
--- /dev/null
@@ -0,0 +1,6 @@
+Package: ttcp
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: A small utility to test TCP connection performance
diff --git a/openwrt/package/ttcp/ttcp.control b/openwrt/package/ttcp/ttcp.control
deleted file mode 100644 (file)
index 3633ef1..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: ttcp
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: A small utility to test TCP connection performance