Treat i686 as an i386 if present, fixes build errors with wireless-tools on i686...
authorFlorian Fainelli <florian@openwrt.org>
Wed, 24 Oct 2007 20:03:14 +0000 (20:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 24 Oct 2007 20:03:14 +0000 (20:03 +0000)
SVN-Revision: 9439

rules.mk

index cd5446acef767af125b5459209894613f3920623..28d28b10c24ab9d4cc980d627472090a46904cb2 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -23,7 +23,7 @@ $(strip $(subst ",,$(1)))
 endef
 #"))
 
-ARCH:=$(call qstrip,$(CONFIG_ARCH))
+ARCH:=$(call qstrip,$(shell echo $(CONFIG_ARCH) | sed -e 's/i[3-9]86/i386/'))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
 BUILD_SUFFIX:=$(call qstrip,$(CONFIG_BUILD_SUFFIX))