[packages] ctorrent: fix build failure on brcm-2.4 with gcc-3.4.6 (closes: #6988)
authorNicolas Thill <nico@openwrt.org>
Mon, 29 Mar 2010 01:14:53 +0000 (01:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 29 Mar 2010 01:14:53 +0000 (01:14 +0000)
SVN-Revision: 20568

net/ctorrent/Makefile

index df9bc65e36803fd8ddffd2da69b3e28d5a22b740..2e72c4aca3166772a362b51c0b1a854ffd2fd18c 100644 (file)
@@ -61,7 +61,7 @@ endef
 CONFIGURE_VARS += \
        CXX="g++-uc" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
-       LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++"
+       LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ $(LIBGCC_S) -lc"
 
 ifeq ($(BUILD_VARIANT),ssl)
        CONFIGURE_ARGS += \