mac80211: don't hardcode /bin/bash
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 5 Feb 2015 23:18:47 +0000 (23:18 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 5 Feb 2015 23:18:47 +0000 (23:18 +0000)
Instead of hardcoding /bin/bash, use /usr/bin/env bash - this fixes the
build on FreeBSD 10.1.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44283

package/kernel/mac80211/patches/001-fix_build.patch

index 99ef50e1829ea6eb2df65e9728a394a833b6fb4e..3c3efdd5a184ae956a82c710215f759eca688915 100644 (file)
@@ -1,5 +1,14 @@
 --- a/Makefile
 +++ b/Makefile
+@@ -5,7 +5,7 @@
+ ifeq ($(KERNELRELEASE),)
+ MAKEFLAGS += --no-print-directory
+-SHELL := /bin/bash
++SHELL := /usr/bin/env bash
+ BACKPORT_PWD := $(shell pwd)
+ KMODDIR ?= updates
 @@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/
  KERNEL_CONFIG := $(KLIB_BUILD)/.config
  KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile