Update Bemusedlinuxserver to latest version. Signed-off-by: Michael Vogt <michu at...
authorTravis Kemen <thepeople@openwrt.org>
Thu, 8 May 2008 01:01:45 +0000 (01:01 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Thu, 8 May 2008 01:01:45 +0000 (01:01 +0000)
SVN-Revision: 11066

utils/bemused/Makefile
utils/bemused/files/bemused.conf
utils/bemused/patches/100-iconv.patch [new file with mode: 0644]

index 08588dd4b6027e0094d90081d925325a9f28878b..bcae09211a39995ff8a9a7ca8f9766f5151f2d51 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bemused-mpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bemused-mpd
-PKG_VERSION:=r047
+PKG_VERSION:=r059
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/382
-PKG_MD5SUM:=f40715812d59d2ab1bd93f96c5e8818b
+PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/512
+PKG_MD5SUM:=76cb208842cce784fd65ec4d392fd6cb
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/bemusedlinuxserver
   SECTION:=utils
   CATEGORY:=Utilities
 define Package/bemusedlinuxserver
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp
+  DEPENDS:=+bluez-libs +glib1 +mpd +libstdcpp +libiconv
   TITLE:=Bemused linux server
   URL:=http://bemused-lnx-mpdhack.origo.ethz.ch/
 endef
   TITLE:=Bemused linux server
   URL:=http://bemused-lnx-mpdhack.origo.ethz.ch/
 endef
@@ -42,8 +42,8 @@ define Build/Compile
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS) " \
        CPPFLAGS="$(TARGET_CPPFLAGS)" \
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS) " \
        CPPFLAGS="$(TARGET_CPPFLAGS)" \
-       INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include" \
-       MYLIBS="-lbluetooth -lglib"
+       INCL="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include -I$(STAGING_DIR)/usr/lib/libiconv/include" \
+       MYLIBS="-lbluetooth -lglib -L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv"
        $(STRIP) $(PKG_BUILD_DIR)/bemusedlinuxserver
 endef
 
        $(STRIP) $(PKG_BUILD_DIR)/bemusedlinuxserver
 endef
 
index f0af55e35dc7fffd25294e67f50762a4028894cb..95acd464ac9c763d471966d0e88df8a7ce848c80 100644 (file)
@@ -3,10 +3,9 @@
 # You only need to set up options which have no default and which ware not optinal
 
 # this is a mpd-hack version by michu@neophob.com
 # You only need to set up options which have no default and which ware not optinal
 
 # this is a mpd-hack version by michu@neophob.com
-# just for information: "xmms" means "mpd"!
 
 # Path to mpd (if mpd is in path only mpd) (default is mpd)
 
 # Path to mpd (if mpd is in path only mpd) (default is mpd)
-xmmsdir=/usr/local/bin/mpd
+mpddir=/usr/local/bin/mpd
 
 # channel for what the serial port service is registered (with sdptool look in README) (default 10)
 # example:
 
 # channel for what the serial port service is registered (with sdptool look in README) (default 10)
 # example:
@@ -31,10 +30,6 @@ channel=3
 # point this directory to the mpd music directory!
 mp3dir=/
 
 # point this directory to the mpd music directory!
 mp3dir=/
 
-# whether to autostart mpd when the server is started (0 (no) or 1 (yes)) (default=1)
-# THIS OPTION IS NOT SUPPORTED!
-# autostartxmms=0
-
 # bookmarks file for URLs of net radio stations (optional)
 bookmarkfile=/etc/bemused-bookmarks
 
 # bookmarks file for URLs of net radio stations (optional)
 bookmarkfile=/etc/bemused-bookmarks
 
diff --git a/utils/bemused/patches/100-iconv.patch b/utils/bemused/patches/100-iconv.patch
new file mode 100644 (file)
index 0000000..ea97ff5
--- /dev/null
@@ -0,0 +1,13 @@
+--- bemused-mpd-r059/mpdctrl.orig      2008-04-23 11:53:58.000000000 +0200
++++ bemused-mpd-r059/mpdctrl.c 2008-04-23 14:36:34.000000000 +0200
+@@ -160,8 +160,8 @@
+     }
+     /* OpenWRT needs a type cast */
+-    /* iconv_value = iconv(i, (const char **)&p1, &fromlen, &p2, &tolen); */
+-    iconv_value = iconv(i, &p1, &fromlen, &p2, &tolen);
++    iconv_value = iconv(i, (const char **)&p1, &fromlen, &p2, &tolen);
++    /* iconv_value = iconv(i, &p1, &fromlen, &p2, &tolen); */
+     if (iconv_value == (size_t) -1) {
+         error ("ICONV ERROR3: failed to convert string, error: %d\n", errno);
+       return "ICONV ERROR3";