change icecast to use libvorbisidec instead of libogg/libvorbis (thanks to David...
authorNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 22:19:21 +0000 (22:19 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 22:19:21 +0000 (22:19 +0000)
SVN-Revision: 2156

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/icecast/Config.in
openwrt/package/icecast/ipkg/icecast.control
openwrt/package/icecast/patches/01-icecast-2.3.0-tremor.patch [new file with mode: 0644]
openwrt/package/libogg/Config.in
openwrt/package/libvorbis/Config.in

index e466dcd90ef5dc0016743fa0ee9cc6fd1e4de73d..c52697a26738db6b30c0902317c60adeac3197d4 100644 (file)
@@ -155,7 +155,6 @@ source "package/gnutls/Config.in" ## libgnutls
 source "package/libgpg-error/Config.in"
 source "package/libid3tag/Config.in"
 source "package/jpeg/Config.in"  # libjpeg
-source "package/libogg/Config.in"
 source "package/libtool/Config.in"  # libltdl
 source "package/lzo/Config.in"  # liblzo
 source "package/libmad/Config.in"
@@ -164,6 +163,7 @@ source "package/mysql/Config.in"  # limysqlclient
 source "package/ncurses/Config.in"  # libncurses
 source "package/libnet/Config.in"
 source "package/libnids/Config.in"
+source "package/libogg/Config.in"
 source "package/opencdk/Config.in"  # libopencdk
 source "package/openldap/Config.in"  # libopenldap
 source "package/openssl/Config.in"  # libopenssl
index 2d02d3d7754daf9687440c9f680498277a093bd4..62ed3260222249c9ab727e70441fa525ae87c153 100644 (file)
@@ -231,7 +231,7 @@ fprobe-compile: libpcap-compile
 gdbserver-compile: ncurses-compile
 gmediaserver-compile: id3lib-compile libupnp-compile
 gnutls-compile: libgcrypt-compile opencdk-compile libtasn1-compile
-icecast-compile: curl-compile libogg-compile libvorbis-compile libxml2-compile libxslt-compile
+icecast-compile: curl-compile libvorbisidec-compile libxml2-compile libxslt-compile
 id3lib-compile: uclibc++-compile zlib-compile
 irssi-compile: glib-compile ncurses-compile
 iptraf-compile: ncurses-compile
index e16b1f0f6cc756b305b04f2980931e5ca7973c64..5252c8c8dbb2e070ae7483f46b6e4d043f795559 100644 (file)
@@ -2,8 +2,7 @@ config BR2_PACKAGE_ICECAST
        tristate "icecast - A streaming media server for Ogg/Vorbis and MP3 audio streams"
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_LIBCURL
-       select BR2_PACKAGE_LIBOGG
-       select BR2_PACKAGE_LIBVORBIS
+       select BR2_PACKAGE_LIBVORBISIDEC
        select BR2_PACKAGE_LIBXML2
        select BR2_PACKAGE_LIBXSLT
        help
@@ -18,8 +17,7 @@ config BR2_PACKAGE_ICECAST
          
          Depends:
           * libcurl
-          * libogg
-          * libvorbis
+          * libvorbisidec
           * libxml2
           * libxslt
          
index 803435971fb9fe8612655c57a216f964122e4ee7..f52dbbd08be91e6641756c65a640efb4cc285ae1 100644 (file)
@@ -3,5 +3,5 @@ Priority: optional
 Section: net
 Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/icecast/
-Depends: libcurl, libogg, libvorbis, libpthread, libxml2, libxslt
+Depends: libcurl, libvorbisidec, libpthread, libxml2, libxslt
 Description: A streaming media server
diff --git a/openwrt/package/icecast/patches/01-icecast-2.3.0-tremor.patch b/openwrt/package/icecast/patches/01-icecast-2.3.0-tremor.patch
new file mode 100644 (file)
index 0000000..ed17084
--- /dev/null
@@ -0,0 +1,153 @@
+diff -rNu icecast-2.3.0.old/configure icecast-2.3.0.new/configure
+--- icecast-2.3.0.old/configure        2005-09-24 07:18:46.000000000 +1000
++++ icecast-2.3.0.new/configure        2005-10-07 22:08:29.000000000 +1000
+@@ -21967,7 +21967,7 @@
+ if test "${xt_cv_lib_ogg+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+-  OGG_LIBS="-logg"
++  OGG_LIBS="-lvorbisidec"
+ #
+ # check if the installed Ogg is sufficiently new.
+@@ -22033,7 +22033,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h.  */
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ int
+ main ()
+ {
+@@ -22188,9 +22188,9 @@
+ fi
+-VORBIS_LIBS="-lvorbis"
+-VORBISFILE_LIBS="-lvorbisfile"
+-VORBISENC_LIBS="-lvorbisenc"
++VORBIS_LIBS="-lvorbisidec"
++VORBISFILE_LIBS="-lvorbisidec"
++VORBISENC_LIBS="-lvorbisidec"
+ xt_save_LIBS="$LIBS"
+ xt_save_LDFLAGS="$LDFLAGS"
+@@ -22327,17 +22327,18 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h.  */
+-#include <vorbis/codec.h>
+-#include <vorbis/vorbisenc.h>
++#include <tremor/ivorbiscodec.h>
+ int
+ main ()
+ {
++/*
+ if ((struct ovectl_ratemanage_arg *) 0)
+   return 0;
+ if (sizeof (struct ovectl_ratemanage_arg))
+   return 0;
++*/
+   ;
+   return 0;
+ }
+diff -rNu icecast-2.3.0.old/src/format_flac.c icecast-2.3.0.new/src/format_flac.c
+--- icecast-2.3.0.old/src/format_flac.c        2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_flac.c        2005-10-07 22:10:24.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <string.h>
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_midi.c icecast-2.3.0.new/src/format_midi.c
+--- icecast-2.3.0.old/src/format_midi.c        2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_midi.c        2005-10-07 22:10:12.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <string.h>
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_ogg.c icecast-2.3.0.new/src/format_ogg.c
+--- icecast-2.3.0.old/src/format_ogg.c 2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_ogg.c 2005-10-07 22:10:02.000000000 +1000
+@@ -24,7 +24,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include "refbuf.h"
+ #include "source.h"
+diff -rNu icecast-2.3.0.old/src/format_ogg.h icecast-2.3.0.new/src/format_ogg.h
+--- icecast-2.3.0.old/src/format_ogg.h 2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_ogg.h 2005-10-07 22:09:51.000000000 +1000
+@@ -18,7 +18,7 @@
+ #ifndef __FORMAT_OGG_H__
+ #define __FORMAT_OGG_H__
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include "refbuf.h"
+ #include "format.h"
+diff -rNu icecast-2.3.0.old/src/format_speex.c icecast-2.3.0.new/src/format_speex.c
+--- icecast-2.3.0.old/src/format_speex.c       2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_speex.c       2005-10-07 22:09:44.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <speex/speex_header.h>
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_theora.c icecast-2.3.0.new/src/format_theora.c
+--- icecast-2.3.0.old/src/format_theora.c      2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_theora.c      2005-10-07 22:09:38.000000000 +1000
+@@ -18,7 +18,7 @@
+ #endif
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <theora/theora.h>
+ typedef struct source_tag source_t;
+diff -rNu icecast-2.3.0.old/src/format_vorbis.c icecast-2.3.0.new/src/format_vorbis.c
+--- icecast-2.3.0.old/src/format_vorbis.c      2005-08-19 12:01:58.000000000 +1000
++++ icecast-2.3.0.new/src/format_vorbis.c      2005-10-07 22:09:29.000000000 +1000
+@@ -18,8 +18,8 @@
+ #endif
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
+-#include <vorbis/codec.h>
++#include <tremor/ogg.h>
++#include <tremor/ivorbiscodec.h>
+ #include <memory.h>
+ #include <string.h>
+diff -rNu icecast-2.3.0.old/src/source.c icecast-2.3.0.new/src/source.c
+--- icecast-2.3.0.old/src/source.c     2005-09-23 06:19:28.000000000 +1000
++++ icecast-2.3.0.new/src/source.c     2005-10-07 22:09:17.000000000 +1000
+@@ -19,7 +19,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <errno.h>
+ #ifndef _WIN32
index 38213a5cc91a0e064e10fe89b3c4a932cbb82071..98632ddb54f801f7591130e61df3fa69af20f50a 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBOGG
        tristate "libogg - The Ogg bitstream handling library"
-       default m if CONFIG_DEVEL
+       default n
        help
          The Ogg bitstream handling library.
          
index ab93bd3922d6f53f697a3355dd9bb0d715684cef..67c5cabd1bc5194590cd86497f352f0409b2e518 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBVORBIS
        tristate "libvorbis - The Vorbis General Audio Compression Codec library"
-       default m if CONFIG_DEVEL
+       default n
        select BR2_PACKAGE_LIBOGG
        help
          The Vorbis General Audio Compression Codec library.