[packages] neon: update to 0.29.3, update configure option name, correct neon-config...
authorStephen Walker <stephendwalker@gmail.com>
Mon, 18 Jan 2010 00:59:10 +0000 (00:59 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Mon, 18 Jan 2010 00:59:10 +0000 (00:59 +0000)
[packages] subversion: restore WebDAV support by correcting --with-neon, remove obsolete configure option

SVN-Revision: 19211

libs/neon/Makefile
net/subversion/Makefile

index 986de3ceae0fc48902a3d0bdd9e580048edb422c..3667a4500a17b050e0a5ead1c7b22a861930058d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=neon
-PKG_VERSION:=0.29.0
+PKG_VERSION:=0.29.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.webdav.org/neon/
-PKG_MD5SUM:=18a3764b70f9317f8b61509fd90d9e7a
+PKG_MD5SUM:=ba1015b59c112d44d7797b62fe7bee51
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +28,6 @@ define Package/libneon
   DEPENDS:=+libopenssl +libexpat
 endef
 
-
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
@@ -36,15 +36,11 @@ CONFIGURE_ARGS += \
        --with-expat \
        --with-ssl="openssl" \
        --without-egd \
-       --without-socks \
+       --without-libproxy \
 
 CONFIGURE_VARS += \
        LDFLAGS="$$$$LDFLAGS -lcrypto -lssl"
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/neon-config $(1)/usr/bin/
@@ -54,7 +50,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libneon.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/neon.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir}/,-I$(1)/usr/include/,g' $(1)/usr/bin/neon-config
+       $(SED) 's,-I$$$${includedir}/,-I$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/neon-config
        $(SED) 's,-L$$$${libdir},,g' $(1)/usr/bin/neon-config
 endef
 
index f799d6c3a311b0aa54c3454f4e69e7ab9f2fdfad..eeaf2a85178578de2a19da160dacee7301f1f453 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
 PKG_VERSION:=1.6.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://subversion.tigris.org/downloads/
 PKG_MD5SUM:=e5109da756d74c7d98f683f004a539af
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -75,7 +75,7 @@ endef
 CONFIGURE_ARGS += \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
-       --with-neon="$(STAGING_DIR)/usr/include/neon" \
+       --with-neon="$(STAGING_DIR)/usr" \
        --disable-mod-activation \
        --without-ruby-sitedir \
        --without-swig \
@@ -85,7 +85,6 @@ CONFIGURE_ARGS += \
        --with-ssl \
        --disable-neon-version-check \
        --with-apxs=no \
-       --with-apache=no \
        --without-sasl \
 
 CONFIGURE_VARS += \