[patchteam] New Package - pyxdg - required for deluge
authorScott V. Kamp <outbackdingo@gmail.com>
Sat, 13 Mar 2010 02:49:08 +0000 (02:49 +0000)
committerScott V. Kamp <outbackdingo@gmail.com>
Sat, 13 Mar 2010 02:49:08 +0000 (02:49 +0000)
Signed off by alexander@sulfrian.net

SVN-Revision: 20171

lang/pyxdg/Makefile [new file with mode: 0644]

diff --git a/lang/pyxdg/Makefile b/lang/pyxdg/Makefile
new file mode 100644 (file)
index 0000000..1eb255c
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pyxdg
+PKG_VERSION:=0.18
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://people.freedesktop.org/~lanius/
+PKG_MD5SUM:=076b57722e91dab8ab83028c6ef9dcea
+
+PKG_BUILD_DEPENDS:=python
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/pyxdg
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=pyxdg
+  URL:=http://freedesktop.org/wiki/Software/pyxdg
+  DEPENDS:=+python
+endef
+
+define Package/pyxdg/description
+  A Python module to deal with freedesktop.org specifications
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/pyxdg/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,pyxdg))