[package] gdb: fix build failure with arm targets
authorNicolas Thill <nico@openwrt.org>
Sun, 20 Dec 2009 23:24:16 +0000 (23:24 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 20 Dec 2009 23:24:16 +0000 (23:24 +0000)
SVN-Revision: 18865

package/gdb/Makefile

index d2bb43be9542b7e3bfbc1e2c484b15d85b1b3661..4ecda6841ce4ba058990dbc8db17c8c675e8abf1 100644 (file)
@@ -42,8 +42,10 @@ define Package/gdbserver/description
  than the one which is running the program being debugged.
 endef
 
  than the one which is running the program being debugged.
 endef
 
+# XXX: add --disable-werror to prevent build failure with arm
 CONFIGURE_ARGS+= \
 CONFIGURE_ARGS+= \
-       --with-system-readline
+       --with-system-readline \
+       --disable-werror \
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"