ramips: rt305x: add support for the ZyXEL NBG-419N board
authorGabor Juhos <juhosg@openwrt.org>
Mon, 22 Aug 2011 20:41:49 +0000 (20:41 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 22 Aug 2011 20:41:49 +0000 (20:41 +0000)
SVN-Revision: 28078

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-nbg-419n.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39

index 1a5747f2f6361cbc6db4b6b3c27c59592bf48865..ba4787bbb35d9dad649e179d82e720e0f21c7c45 100755 (executable)
@@ -42,6 +42,9 @@ get_status_led() {
        mofi3500-3gn)
                status_led="mofi3500-3gn:green:status"
                ;;
+       nbg-419n)
+               status_led="nbg-419n:green:power"
+               ;;
        nw718)
                status_led="nw718:amber:cpu"
                ;;
index 0f50c9bc1b5e772e3e3a210fb079f6e321a6366e..73dc25529b3cc2971e926365ada970c39aed89bb 100644 (file)
@@ -50,6 +50,7 @@ case "$FIRMWARE" in
        hw550-3g | \
        mofi3500-3gn | \
        pwh2004 | \
+       nbg-419n | \
        nw718 | \
        rt-n15 | \
        v22rw-2x2 | \
index 65ebf84016b4125b126873baa63abb348524dce4..227ca821a3ff2258d5bcb3698961cd9f7990fd64 100755 (executable)
@@ -34,6 +34,9 @@ ramips_board_name() {
        *"MoFi Network MOFI3500-3GN")
                name="mofi3500-3gn"
                ;;
+       *"NBG-419N")
+               name="nbg-419n"
+               ;;
        *"NW718")
                name="nw718"
                ;;
index dda4a67577e8de9d12bbaa1d404850b1dccfada5..58ba0f0fc6f2a35d16d0625e956df10501ec1cda 100755 (executable)
@@ -14,7 +14,7 @@ platform_check_image() {
        [ "$ARGC" -gt 1 ] && return 1
 
        case "$board" in
-       dir-300-b1 | dir-600-b1 | dir-600-b2 | fonera20n | nw718 | rt-g32-b1 | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
+       dir-300-b1 | dir-600-b1 | dir-600-b2 | fonera20n | nbg-419n | nw718 | rt-g32-b1 | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
                [ "$magic" != "2705" ] && {
                        echo "Invalid image type."
                        return 1
index 01e79224556a6fa0282006c06765475a4c68648e..2145becfcb0f84c7fddd09a86b40661b854ae70c 100644 (file)
@@ -30,6 +30,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
        RAMIPS_MACH_HW550_3G,           /* Aztech HW550-3G */
        RAMIPS_MACH_MOFI3500_3GN,       /* MoFi Network MOFI3500-3GN */
+       RAMIPS_MACH_NBG_419N,           /* ZyXEL NBG-419N */
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
index 86ccfa7e82f0e1246ac5d109ced0ee8d73100fd7..392fb4f92bcecbac2ae311d7ca17b87633f8a27f 100644 (file)
@@ -66,6 +66,11 @@ config RT305X_MACH_WCR150GN
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_NBG_419N
+       bool "ZyXEL NBG-419N support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 endmenu
 
 endif
index 85fce923fb7276dbe71b202628f60559cb1bc893..2853429e85e049dba676b5ec504bcdbc355929d2 100644 (file)
@@ -17,6 +17,7 @@ obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
+obj-$(CONFIG_RT305X_MACH_NBG_419N)     += mach-nbg-419n.o
 obj-$(CONFIG_RT305X_MACH_NW718)                += mach-nw718.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-nbg-419n.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-nbg-419n.c
new file mode 100644 (file)
index 0000000..4227654
--- /dev/null
@@ -0,0 +1,111 @@
+/*
+ *  ZyXEL NBG-419N board support
+ *
+ *  Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define NBG_419N_GPIO_LED_POWER                9
+#define NBG_419N_GPIO_LED_WPS          14
+
+#define NBG_419N_GPIO_BUTTON_WPS       0       /* active low */
+#define NBG_419N_GPIO_BUTTON_RESET     10      /* active low */
+
+#define NBG_419N_BUTTONS_POLL_INTERVAL 20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition nbg_419n_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "config",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x3b0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data nbg_419n_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(nbg_419n_partitions),
+       .parts          = nbg_419n_partitions,
+#endif
+};
+
+static struct gpio_led nbg_419n_leds_gpio[] __initdata = {
+       {
+               .name           = "nbg-419n:green:power",
+               .gpio           = NBG_419N_GPIO_LED_POWER,
+               .active_low     = 1,
+       }, {
+               .name           = "nbg-419n:green:wps",
+               .gpio           = NBG_419N_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button nbg_419n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = NBG_419N_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = NBG_419N_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init nbg_419n_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_flash(0, &nbg_419n_flash_data);
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(nbg_419n_leds_gpio),
+                                 nbg_419n_leds_gpio);
+       ramips_register_gpio_buttons(-1, NBG_419N_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(nbg_419n_gpio_buttons),
+                                    nbg_419n_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_NBG_419N, "NBG-419N", "ZyXEL NBG-419N", nbg_419n_init);
index 6cdb55c72440a6cc4a16e9a4b40eaa8b3bc8a0b0..9136f3a5e263f3a3789c573dd82919c63e76c4cd 100644 (file)
@@ -154,6 +154,10 @@ define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
 endef
 
+define Image/Build/Profile/NBG419N
+       $(call Image/Build/Template/GENERIC_4M,$(1),nbg-419n,NBG-419N)
+endef
+
 define Image/Build/Profile/NW718
        $(call Image/Build/Template/NW718,$(1),nw718,NW718)
 endef
@@ -237,6 +241,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
+       $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
index 3276d14924c8c7f38649b88e2fa1c8cc7e68a2ef..643c938422e9211ba70824b86096e8175b2db76b 100644 (file)
@@ -98,6 +98,7 @@ CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_HW550_3G=y
 CONFIG_RT305X_MACH_MOFI3500_3GN=y
 CONFIG_RT305X_MACH_NW718=y
+CONFIG_RT305X_MACH_NBG_419N=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_V22RW_2X2=y