ralink: add support for Kingston MLWG2
authorJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 07:07:36 +0000 (07:07 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 07:07:36 +0000 (07:07 +0000)
This patch adds support for the Kingston Mobilelite Wireless G2 (MLWG2)

http://wiki.openwrt.org/toh/kingston/mlwg2

https://github.com/gmacario/kingston-mlwg2-hack/wiki/Testing-OpenWrt-on-MLWG2

Tested-by: Gianpaolo Macario <gmacario@gmail.com>
Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
SVN-Revision: 43990

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/MLWG2.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index c42b31feb8c10046c6009aa68ab9eca419b8cdad..dfd0ca7049db097200c5b5852d60bf27ba6a5a02 100755 (executable)
@@ -130,6 +130,10 @@ case $board in
                set_wifi_led "kingston:blue:wifi"
                ucidef_set_led_default "system" "system" "kingston:blue:system" "1"
                ;;
                set_wifi_led "kingston:blue:wifi"
                ucidef_set_led_default "system" "system" "kingston:blue:system" "1"
                ;;
+       mlwg2)
+               set_wifi_led "kingston:blue:wifi"
+               ucidef_set_led_default "system" "system" "kingston:blue:system" "1"
+               ;;
        mofi3500-3gn)
                set_usb_led "mofi3500-3gn:green:usb"
                ;;
        mofi3500-3gn)
                set_usb_led "mofi3500-3gn:green:usb"
                ;;
index a86466e5e7adac6fac10d711ab4c8516b3fef83c..aad119738b5b6de680d3cea9856301defd47afbf 100755 (executable)
@@ -61,6 +61,9 @@ ramips_setup_interfaces()
        mlw221)
                ucidef_set_interface_lan "eth0.2"
                ;;
        mlw221)
                ucidef_set_interface_lan "eth0.2"
                ;;
+       mlwg2)
+               ucidef_set_interface_lan "eth0.1"
+               ;;
 
        wizard8800 | \
        wl-330n | \
 
        wizard8800 | \
        wl-330n | \
index 103dfcd23682382349324ffb11cc3153c18cd000..65ef0db96a63d39f0e888c5401045063b358dbe1 100755 (executable)
@@ -88,6 +88,9 @@ get_status_led() {
        mlw221)
                status_led="kingston:blue:status"
                ;;
        mlw221)
                status_led="kingston:blue:status"
                ;;
+       mlwg2)
+               status_led="kingston:blue:system"
+               ;;
        mofi3500-3gn)
                status_led="mofi3500-3gn:green:status"
                ;;
        mofi3500-3gn)
                status_led="mofi3500-3gn:green:status"
                ;;
index 540da335c6866b92025202d0593bef34ae38f399..379713bf21d49e26307228cb2501312d4461490e 100755 (executable)
@@ -187,6 +187,9 @@ ramips_board_detect() {
        *"Kingston MLW221")
                name="mlw221"
                ;;
        *"Kingston MLW221")
                name="mlw221"
                ;;
+       *"Kingston MLWG2")
+               name="mlwg2"
+               ;;
        *"Linksys E1700")
                name="e1700"
                ;;
        *"Linksys E1700")
                name="e1700"
                ;;
index 95cad633a56a4e9f1c40e14fba14c84835eac96d..b5eecfc2992d4961bd06701f2133d00857e41eaa 100755 (executable)
@@ -58,6 +58,7 @@ platform_check_image() {
        m3 | \
        m4 | \
        mlw221 | \
        m3 | \
        m4 | \
        mlw221 | \
+       mlwg2 | \
        mofi3500-3gn | \
        mpr-a1 | \
        mpr-a2 | \
        mofi3500-3gn | \
        mpr-a1 | \
        mpr-a2 | \
diff --git a/target/linux/ramips/dts/MLWG2.dts b/target/linux/ramips/dts/MLWG2.dts
new file mode 100644 (file)
index 0000000..c7ce146
--- /dev/null
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "mlwG2", "ralink,mt7620n-soc";
+       model = "Kingston MLWG2";
+
+       palmbus@10000000 {
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l12805d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xf60000>;
+                               };
+
+                               partition@fb0000 {
+                                       label = "user-config";
+                                       reg = <0xfb0000 0x50000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "wllll";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               ralink,group = "i2c", "ephy", "wled";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               system {
+                       label = "kingston:blue:system";
+                       gpios = <&gpio2 3 1>;
+               };
+               wifi {
+                       label = "kingston:blue:wifi";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+               system {
+                       label = "system";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x211>;
+               };
+       };
+};
index 82cadd742b725fc03e4e76d0cd510cb657bf5ea1..21c8a8ddc95f24329b60b116b76bb9168714f1a7 100644 (file)
@@ -828,6 +828,7 @@ Image/Build/Profile/MZK-750DHP=$(call BuildFirmware/Default8M/$(1),$(1),mzk-750d
 Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),Lenovo-y1,Y1)
 Image/Build/Profile/Y1S=$(call BuildFirmware/Default16M/$(1),$(1),Lenovo-y1s,Y1S)
 Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW221)
 Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),Lenovo-y1,Y1)
 Image/Build/Profile/Y1S=$(call BuildFirmware/Default16M/$(1),$(1),Lenovo-y1s,Y1S)
 Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW221)
+Image/Build/Profile/MLWG2=$(call BuildFirmware/Default16M/$(1),$(1),mlwg2,MLWG2)
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
 Image/Build/Profile/WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),wr8305rt,WR8305RT)
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
 Image/Build/Profile/WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),wr8305rt,WR8305RT)
@@ -855,6 +856,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/Y1,$(1))
        $(call Image/Build/Profile/Y1S,$(1))
        $(call Image/Build/Profile/MLW221,$(1))
        $(call Image/Build/Profile/Y1,$(1))
        $(call Image/Build/Profile/Y1S,$(1))
        $(call Image/Build/Profile/MLW221,$(1))
+       $(call Image/Build/Profile/MLWG2,$(1))
        $(call Image/Build/Profile/WMR300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
        $(call Image/Build/Profile/WR8305RT,$(1))
        $(call Image/Build/Profile/WMR300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
        $(call Image/Build/Profile/WR8305RT,$(1))