add apache
authorMartin Janitschke <noeoeh@web.de>
Mon, 16 Jul 2007 20:58:42 +0000 (20:58 +0000)
committerMartin Janitschke <noeoeh@web.de>
Mon, 16 Jul 2007 20:58:42 +0000 (20:58 +0000)
SVN-Revision: 8010

net/apache/Makefile [new file with mode: 0644]
net/apache/files/etc/httpd.conf [new file with mode: 0644]
net/apache/patches/001-Makefile_in.patch [new file with mode: 0644]
net/apache/patches/002-test_char_h.patch [new file with mode: 0644]
net/apache/patches/003-logdir_fix.patch [new file with mode: 0644]
net/apache/patches/004-pidfile_fix.patch [new file with mode: 0644]

diff --git a/net/apache/Makefile b/net/apache/Makefile
new file mode 100644 (file)
index 0000000..9fa7a40
--- /dev/null
@@ -0,0 +1,139 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$ 
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=apache
+PKG_VERSION:=2.2.4
+PKG_RELEASE:=1
+PKG_SOURCE_NAME:=httpd
+
+PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/
+PKG_MD5SUM:=3add41e0b924d4bb53c2dee55a38c09e
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/apache/Default
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+apr +apr-util +zlib +libexpat +libpcre +libopenssl +libsqlite3
+  TITLE:=The Apache Web Server
+  URL:=http://httpd.apache.org/
+  SUBMENU:=apache
+endef
+
+define Package/apache-server
+  $(call Package/apache/Default)
+  TITLE:=The apache server & and some tools
+  DESCRIPTION:=\
+       Take care that you don't include apache at the moment into your image\\\
+       please select it only as module because busybox will override\\\
+       /usr/sbin/httpd. It'll be solved soon. If you need to include this\\\
+       package in the image anyway, remove httpd from busybox\\\
+       (Base system --> Configuration --> Networking Utilities --> httpd).\\\
+       Also you should take care for the initscripts, apache's httpd isn't\\\
+       compatible with the one from busybox, so if you want to use apache\\\
+       for running your webif, you'll need to change the parameters in the\\\
+       scripts and configure the rest in /etc/httpd.conf.
+endef
+
+define Package/apache-icons
+  $(call Package/apache/Default)
+  TITLE:=Icons from Apache
+  DEPENDS:=
+endef
+
+define Build/Configure 
+       $(call Build/Configure/Default, \
+               --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
+               --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
+               --with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
+               --enable-http \
+               --enable-ssl \
+               --disable-disk-cache \
+               --enable-maintainer-mode \
+               --enable-mime-magic \
+               --without-suexec-bin \
+               ap_void_ptr_lt_long=no \
+               logfiledir="/var/log" \
+       )
+endef
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       rm -rf  $(PKG_INSTALL_DIR)/usr/man/ \
+               $(PKG_INSTALL_DIR)/usr/share/manual/
+       # if you need docs take a look into the build-dir :)
+       mkdir -p $(STAGING_DIR)/etc
+       $(CP)   $(PKG_INSTALL_DIR)/etc/* \
+               $(STAGING_DIR)/etc
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP)   $(PKG_INSTALL_DIR)/usr/include/* \
+               $(STAGING_DIR)/usr/include
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/httpd.exp \
+               $(STAGING_DIR)/usr/lib
+       mkdir -p $(STAGING_DIR)/usr/sbin
+       $(CP)   $(PKG_INSTALL_DIR)/usr/sbin/* \
+               $(STAGING_DIR)/usr/sbin
+       mkdir -p $(STAGING_DIR)/usr/share
+       $(CP)   $(PKG_INSTALL_DIR)/usr/share/* \
+               $(STAGING_DIR)/usr/share
+endef
+
+define Build/UninstallDev
+       rm -rf  $(STAGING_DIR)/usr/include/{ap_*,http*,mod_*,mpm*,os.h,scoreboard.h,unixd.h,util_*} \
+               $(STAGING_DIR)/etc/{httpd.conf,magic,mime.types,extra,original} \
+               $(STAGING_DIR)/usr/sbin/{ab,apachectl,apxs,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} \
+               $(STAGING_DIR)/usr/share/{error,icons,htdocs,cgi-bin,build} \
+               $(STAGING_DIR)/usr/lib/httpd.exp
+endef
+
+define Package/apache-server/preinst
+       rm /usr/sbin/httpd
+       echo -e "You should take a look in the initscripts, busybox's httpd \n\
+       uses some parameters which are maybe unsupported by apache."
+endef
+
+define Package/apache-server/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       # we don't need apxs on the router, it's just for building apache modules.  
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/{error,htdocs,cgi-bin,build} $(1)/usr/share/
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/{magic,mime.types,extra} $(1)/etc/
+       $(CP) ./files/etc/httpd.conf $(1)/etc/
+endef
+
+define Package/apache-server/postrm
+       rm -rf /usr/sbin/httpd
+       ln -s /bin/busybox /usr/sbin/httpd
+       echo -e "You may need to change your initscripts back for the use \n\
+               with busybox's httpd."
+endef
+
+define Package/apache-icons/install
+       $(INSTALL_DIR) $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/icons $(1)/usr/share/
+endef
+
+$(eval $(call BuildPackage,apache-server))
+$(eval $(call BuildPackage,apache-icons))
diff --git a/net/apache/files/etc/httpd.conf b/net/apache/files/etc/httpd.conf
new file mode 100644 (file)
index 0000000..d979c46
--- /dev/null
@@ -0,0 +1,406 @@
+#
+# This is the main Apache HTTP server configuration file.  It contains the
+# configuration directives that give the server its instructions.
+# See <URL:http://httpd.apache.org/docs/2.2> for detailed information.
+# In particular, see 
+# <URL:http://httpd.apache.org/docs/2.2/mod/directives.html>
+# for a discussion of each configuration directive.
+#
+# Do NOT simply read the instructions in here without understanding
+# what they do.  They're here only as hints or reminders.  If you are unsure
+# consult the online docs. You have been warned.  
+#
+# Configuration and logfile names: If the filenames you specify for many
+# of the server's control files begin with "/" (or "drive:/" for Win32), the
+# server will use that explicit path.  If the filenames do *not* begin
+# with "/", the value of ServerRoot is prepended -- so "/var/log/foo.log"
+# with ServerRoot set to "/usr" will be interpreted by the
+# server as "/usr//var/log/foo.log".
+
+#
+# ServerRoot: The top of the directory tree under which the server's
+# configuration, error, and log files are kept.
+#
+# Do not add a slash at the end of the directory path.  If you point
+# ServerRoot at a non-local disk, be sure to point the LockFile directive
+# at a local disk.  If you wish to share the same ServerRoot for multiple
+# httpd daemons, you will need to change at least LockFile and PidFile.
+#
+ServerRoot "/usr"
+
+#
+# Listen: Allows you to bind Apache to specific IP addresses and/or
+# ports, instead of the default. See also the <VirtualHost>
+# directive.
+#
+# Change this to Listen on specific IP addresses as shown below to 
+# prevent Apache from glomming onto all bound IP addresses.
+#
+#Listen 12.34.56.78:80
+Listen 80
+
+#
+# Dynamic Shared Object (DSO) Support
+#
+# To be able to use the functionality of a module which was built as a DSO you
+# have to place corresponding `LoadModule' lines at this location so the
+# directives contained in it are actually available _before_ they are used.
+# Statically compiled modules (those listed by `httpd -l') do not need
+# to be loaded here.
+#
+# Example:
+# LoadModule foo_module modules/mod_foo.so
+#
+
+<IfModule !mpm_netware_module>
+#
+# If you wish httpd to run as a different user or group, you must run
+# httpd as root initially and it will switch.  
+#
+# User/Group: The name (or #number) of the user/group to run httpd as.
+# It is usually good practice to create a dedicated user and group for
+# running httpd, as with most system services.
+#
+User nobody
+Group nogroup
+</IfModule>
+
+# 'Main' server configuration
+#
+# The directives in this section set up the values used by the 'main'
+# server, which responds to any requests that aren't handled by a
+# <VirtualHost> definition.  These values also provide defaults for
+# any <VirtualHost> containers you may define later in the file.
+#
+# All of these directives may appear inside <VirtualHost> containers,
+# in which case these default settings will be overridden for the
+# virtual host being defined.
+#
+
+#
+# ServerAdmin: Your address, where problems with the server should be
+# e-mailed.  This address appears on some server-generated pages, such
+# as error documents.  e.g. admin@your-domain.com
+#
+ServerAdmin you@example.com
+
+#
+# ServerName gives the name and port that the server uses to identify itself.
+# This can often be determined automatically, but we recommend you specify
+# it explicitly to prevent problems during startup.
+#
+# If your host doesn't have a registered DNS name, enter its IP address here.
+#
+#ServerName www.example.com:80
+
+#
+# DocumentRoot: The directory out of which you will serve your
+# documents. By default, all requests are taken from this directory, but
+# symbolic links and aliases may be used to point to other locations.
+#
+DocumentRoot "/usr/share/htdocs"
+
+#
+# Each directory to which Apache has access can be configured with respect
+# to which services and features are allowed and/or disabled in that
+# directory (and its subdirectories). 
+#
+# First, we configure the "default" to be a very restrictive set of 
+# features.  
+#
+<Directory />
+    Options FollowSymLinks
+    AllowOverride None
+    Order deny,allow
+    Deny from all
+</Directory>
+
+#
+# Note that from this point forward you must specifically allow
+# particular features to be enabled - so if something's not working as
+# you might expect, make sure that you have specifically enabled it
+# below.
+#
+
+#
+# This should be changed to whatever you set DocumentRoot to.
+#
+<Directory "/usr/share/htdocs">
+    #
+    # Possible values for the Options directive are "None", "All",
+    # or any combination of:
+    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
+    #
+    # Note that "MultiViews" must be named *explicitly* --- "Options All"
+    # doesn't give it to you.
+    #
+    # The Options directive is both complicated and important.  Please see
+    # http://httpd.apache.org/docs/2.2/mod/core.html#options
+    # for more information.
+    #
+    Options Indexes FollowSymLinks
+
+    #
+    # AllowOverride controls what directives may be placed in .htaccess files.
+    # It can be "All", "None", or any combination of the keywords:
+    #   Options FileInfo AuthConfig Limit
+    #
+    AllowOverride None
+
+    #
+    # Controls who can get stuff from this server.
+    #
+    Order allow,deny
+    Allow from all
+
+</Directory>
+
+#
+# DirectoryIndex: sets the file that Apache will serve if a directory
+# is requested.
+#
+<IfModule dir_module>
+    DirectoryIndex index.html
+</IfModule>
+
+#
+# The following lines prevent .htaccess and .htpasswd files from being 
+# viewed by Web clients. 
+#
+<FilesMatch "^\.ht">
+    Order allow,deny
+    Deny from all
+    Satisfy All
+</FilesMatch>
+
+#
+# ErrorLog: The location of the error log file.
+# If you do not specify an ErrorLog directive within a <VirtualHost>
+# container, error messages relating to that virtual host will be
+# logged here.  If you *do* define an error logfile for a <VirtualHost>
+# container, that host's errors will be logged there and not here.
+#
+ErrorLog /var/log/error_log
+
+#
+# LogLevel: Control the number of messages logged to the error_log.
+# Possible values include: debug, info, notice, warn, error, crit,
+# alert, emerg.
+#
+LogLevel debug
+
+<IfModule log_config_module>
+    #
+    # The following directives define some format nicknames for use with
+    # a CustomLog directive (see below).
+    #
+    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
+    LogFormat "%h %l %u %t \"%r\" %>s %b" common
+
+    <IfModule logio_module>
+      # You need to enable mod_logio.c to use %I and %O
+      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
+    </IfModule>
+
+    #
+    # The location and format of the access logfile (Common Logfile Format).
+    # If you do not define any access logfiles within a <VirtualHost>
+    # container, they will be logged here.  Contrariwise, if you *do*
+    # define per-<VirtualHost> access logfiles, transactions will be
+    # logged therein and *not* in this file.
+    #
+    CustomLog /var/log/access_log common
+
+    #
+    # If you prefer a logfile with access, agent, and referer information
+    # (Combined Logfile Format) you can use the following directive.
+    #
+    #CustomLog /var/log/access_log combined
+</IfModule>
+
+<IfModule alias_module>
+    #
+    # Redirect: Allows you to tell clients about documents that used to 
+    # exist in your server's namespace, but do not anymore. The client 
+    # will make a new request for the document at its new location.
+    # Example:
+    # Redirect permanent /foo http://www.example.com/bar
+
+    #
+    # Alias: Maps web paths into filesystem paths and is used to
+    # access content that does not live under the DocumentRoot.
+    # Example:
+    # Alias /webpath /full/filesystem/path
+    #
+    # If you include a trailing / on /webpath then the server will
+    # require it to be present in the URL.  You will also likely
+    # need to provide a <Directory> section to allow access to
+    # the filesystem path.
+
+    #
+    # ScriptAlias: This controls which directories contain server scripts. 
+    # ScriptAliases are essentially the same as Aliases, except that
+    # documents in the target directory are treated as applications and
+    # run by the server when requested rather than as documents sent to the
+    # client.  The same rules about trailing "/" apply to ScriptAlias
+    # directives as to Alias.
+    #
+    ScriptAlias /cgi-bin/ "/usr/share/cgi-bin/"
+
+</IfModule>
+
+<IfModule cgid_module>
+    #
+    # ScriptSock: On threaded servers, designate the path to the UNIX
+    # socket used to communicate with the CGI daemon of mod_cgid.
+    #
+    #Scriptsock /var/log/cgisock
+</IfModule>
+
+#
+# "/usr/share/cgi-bin" should be changed to whatever your ScriptAliased
+# CGI directory exists, if you have that configured.
+#
+<Directory "/usr/share/cgi-bin">
+    AllowOverride None
+    Options None
+    Order allow,deny
+    Allow from all
+</Directory>
+
+#
+# DefaultType: the default MIME type the server will use for a document
+# if it cannot otherwise determine one, such as from filename extensions.
+# If your server contains mostly text or HTML documents, "text/plain" is
+# a good value.  If most of your content is binary, such as applications
+# or images, you may want to use "application/octet-stream" instead to
+# keep browsers from trying to display binary files as though they are
+# text.
+#
+DefaultType text/plain
+
+<IfModule mime_module>
+    #
+    # TypesConfig points to the file containing the list of mappings from
+    # filename extension to MIME-type.
+    #
+    TypesConfig /etc/mime.types
+
+    #
+    # AddType allows you to add to or override the MIME configuration
+    # file specified in TypesConfig for specific file types.
+    #
+    #AddType application/x-gzip .tgz
+    #
+    # AddEncoding allows you to have certain browsers uncompress
+    # information on the fly. Note: Not all browsers support this.
+    #
+    #AddEncoding x-compress .Z
+    #AddEncoding x-gzip .gz .tgz
+    #
+    # If the AddEncoding directives above are commented-out, then you
+    # probably should define those extensions to indicate media types:
+    #
+    AddType application/x-compress .Z
+    AddType application/x-gzip .gz .tgz
+
+    #
+    # AddHandler allows you to map certain file extensions to "handlers":
+    # actions unrelated to filetype. These can be either built into the server
+    # or added with the Action directive (see below)
+    #
+    # To use CGI scripts outside of ScriptAliased directories:
+    # (You will also need to add "ExecCGI" to the "Options" directive.)
+    #
+    #AddHandler cgi-script .cgi
+
+    # For type maps (negotiated resources):
+    #AddHandler type-map var
+
+    #
+    # Filters allow you to process content before it is sent to the client.
+    #
+    # To parse .shtml files for server-side includes (SSI):
+    # (You will also need to add "Includes" to the "Options" directive.)
+    #
+    #AddType text/html .shtml
+    #AddOutputFilter INCLUDES .shtml
+</IfModule>
+
+#
+# The mod_mime_magic module allows the server to use various hints from the
+# contents of the file itself to determine its type.  The MIMEMagicFile
+# directive tells the module where the hint definitions are located.
+#
+MIMEMagicFile /etc/magic
+
+#
+# Customizable error responses come in three flavors:
+# 1) plain text 2) local redirects 3) external redirects
+#
+# Some examples:
+#ErrorDocument 500 "The server made a boo boo."
+#ErrorDocument 404 /missing.html
+#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
+#ErrorDocument 402 http://www.example.com/subscription_info.html
+#
+
+#
+# EnableMMAP and EnableSendfile: On systems that support it, 
+# memory-mapping or the sendfile syscall is used to deliver
+# files.  This usually improves server performance, but must
+# be turned off when serving from networked-mounted 
+# filesystems or if support for these functions is otherwise
+# broken on your system.
+#
+#EnableMMAP off
+EnableSendfile off
+
+# Supplemental configuration
+#
+# The configuration files in the /etc/extra/ directory can be 
+# included to add extra features or to modify the default configuration of 
+# the server, or you may simply copy their contents here and change as 
+# necessary.
+
+# Server-pool management (MPM specific)
+## Include /etc/extra/httpd-mpm.conf
+
+# Multi-language error messages
+## Include /etc/extra/httpd-multilang-errordoc.conf
+
+# Fancy directory listings
+## Include /etc/extra/httpd-autoindex.conf
+
+# Language settings
+## Include /etc/extra/httpd-languages.conf
+
+# User home directories
+## Include /etc/extra/httpd-userdir.conf
+
+# Real-time info on requests and configuration
+## Include /etc/extra/httpd-info.conf
+
+# Virtual hosts
+## Include /etc/extra/httpd-vhosts.conf
+
+# Local access to the Apache HTTP Server Manual
+## Include /etc/extra/httpd-manual.conf
+
+# Distributed authoring and versioning (WebDAV)
+## Include /etc/extra/httpd-dav.conf
+
+# Various default settings
+## Include /etc/extra/httpd-default.conf
+
+# Secure (SSL/TLS) connections
+## Include /etc/extra/httpd-ssl.conf
+#
+# Note: The following must must be present to support
+#       starting without SSL on platforms with no /dev/random equivalent
+#       but a statically compiled-in mod_ssl.
+#
+#<IfModule ssl_module>
+#SSLRandomSeed startup builtin
+#SSLRandomSeed connect builtin
+#</IfModule>
diff --git a/net/apache/patches/001-Makefile_in.patch b/net/apache/patches/001-Makefile_in.patch
new file mode 100644 (file)
index 0000000..1ae3152
--- /dev/null
@@ -0,0 +1,14 @@
+--- httpd-2.2.4.orig/server/Makefile.in        2007-07-02 03:30:22.000000000 +0200
++++ httpd-2.2.4/server/Makefile.in     2007-07-02 03:47:35.000000000 +0200
+@@ -26,7 +26,10 @@
+       $(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS)
+ test_char.h: gen_test_char
+-      ./gen_test_char > test_char.h
++      true
++#     ./gen_test_char > test_char.h
++#     doesn't matter if you run it on the buildhost or on an wl500gd,
++#     same output on both, so i just patched in the test_char.h :).
+ util.lo: test_char.h
diff --git a/net/apache/patches/002-test_char_h.patch b/net/apache/patches/002-test_char_h.patch
new file mode 100644 (file)
index 0000000..7847afd
--- /dev/null
@@ -0,0 +1,26 @@
+--- httpd-2.2.4.orig/server/test_char.h        2007-07-02 03:30:22.000000000 +0200
++++ httpd-2.2.4/server/test_char.h     2007-07-02 03:45:58.000000000 +0200
+@@ -0,0 +1,23 @@
++/* this file is automatically generated by gen_test_char, do not edit */
++#define T_ESCAPE_SHELL_CMD     (1)
++#define T_ESCAPE_PATH_SEGMENT  (2)
++#define T_OS_ESCAPE_PATH       (4)
++#define T_HTTP_TOKEN_STOP      (8)
++#define T_ESCAPE_LOGITEM       (16)
++#define T_ESCAPE_FORENSIC      (32)
++
++static const unsigned char test_char_table[256] = {
++    32,62,62,62,62,62,62,62,62,62,63,62,62,62,62,62,62,62,62,62,
++    62,62,62,62,62,62,62,62,62,62,62,62,14,0,23,6,1,38,1,1,
++    9,9,1,0,8,0,0,10,0,0,0,0,0,0,0,0,0,0,40,15,
++    15,8,15,15,8,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
++    0,0,0,0,0,0,0,0,0,0,0,15,31,15,7,0,7,0,0,0,
++    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
++    0,0,0,15,39,15,1,62,54,54,54,54,54,54,54,54,54,54,54,54,
++    54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
++    54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
++    54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
++    54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
++    54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,
++    54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54 
++};
diff --git a/net/apache/patches/003-logdir_fix.patch b/net/apache/patches/003-logdir_fix.patch
new file mode 100644 (file)
index 0000000..f306c60
--- /dev/null
@@ -0,0 +1,33 @@
+--- httpd-2.2.4.orig/build/mkconfNW.awk        2007-07-02 03:30:22.000000000 +0200
++++ httpd-2.2.4/build/mkconfNW.awk     2007-07-15 21:29:01.000000000 +0200
+@@ -23,7 +23,7 @@
+     A["sysconfdir"] = "conf"
+     A["iconsdir"] = "icons"
+     A["manualdir"] = "manual"
+-    A["runtimedir"] = "logs"
++    A["runtimedir"] = "log"
+     A["errordir"] = "error"
+     A["proxycachedir"] = "proxy"
+--- httpd-2.2.4.orig/config.layout     2007-07-02 03:30:22.000000000 +0200
++++ httpd-2.2.4/config.layout  2007-07-15 22:03:15.000000000 +0200
+@@ -28,8 +28,8 @@
+     cgidir:        ${datadir}/cgi-bin
+     includedir:    ${prefix}/include
+     localstatedir: ${prefix}
+-    runtimedir:    ${localstatedir}/logs
+-    logfiledir:    ${localstatedir}/logs
++    runtimedir:    ${localstatedir}/log
++    logfiledir:    ${localstatedir}/log
+     proxycachedir: ${localstatedir}/proxy
+ </Layout>
+@@ -150,7 +150,7 @@
+     includedir:    ${prefix}/include
+     localstatedir: /var${prefix}
+     runtimedir:    ${localstatedir}/run
+-    logfiledir:    ${localstatedir}/logs
++    logfiledir:    ${localstatedir}/log
+     proxycachedir: ${localstatedir}/proxy
+ </Layout>
diff --git a/net/apache/patches/004-pidfile_fix.patch b/net/apache/patches/004-pidfile_fix.patch
new file mode 100644 (file)
index 0000000..b192e0a
--- /dev/null
@@ -0,0 +1,11 @@
+--- httpd-2.2.4.orig/include/scoreboard.h      2007-07-02 03:30:23.000000000 +0200
++++ httpd-2.2.4/include/scoreboard.h   2007-07-15 23:43:19.000000000 +0200
+@@ -42,7 +42,7 @@
+ /* Scoreboard file, if there is one */
+ #ifndef DEFAULT_SCOREBOARD
+-#define DEFAULT_SCOREBOARD "logs/apache_runtime_status"
++#define DEFAULT_SCOREBOARD "log/apache_runtime_status"
+ #endif
+ /* Scoreboard info on a process is, for now, kept very brief ---