Port nocatsplash to -ng
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Aug 2006 12:36:46 +0000 (12:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Aug 2006 12:36:46 +0000 (12:36 +0000)
SVN-Revision: 4484

net/nocatsplash/Makefile [new file with mode: 0644]
net/nocatsplash/patches/openwrt-firewall.patch [new file with mode: 0644]

diff --git a/net/nocatsplash/Makefile b/net/nocatsplash/Makefile
new file mode 100644 (file)
index 0000000..9892e0e
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nocatsplash
+PKG_VERSION:=0.92
+PKG_RELEASE:=1
+PKG_MD5SUM:=e0fcc0effe52e63bc31070d16d0b4a81
+
+PKG_SOURCE_URL:=http://wifi.rulez.org/~josephus/
+PKG_SOURCE:=NoCatSplash-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/NoCatSplash-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nocatsplash
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+glib
+  TITLE:=Open public network gateway daemon
+  DESCRIPTION:=NoCatSplash is an Open Public Network Gateway Daemon.\\\
+       It performs as a [captive/open/active] portal. When run on a gateway/router\\\
+       on a network, all web requests are redirected until the client either logs\\\
+       in or clicks "I Accept" to an AUP. The gateway daemon then changes the\\\
+       firewall rules on the gateway to pass traffic for that client (based on IP\\\
+       address and MAC address).\\\
+  URL:=http://nocat.net
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,        --with-firewall=iptables \
+                 --with-glib-prefix="$(STAGING_DIR)/usr")
+endef
+
+define Build/Compile   
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/nocatsplash/install     
+       mkdir -p $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/ 
+endef
+
+$(eval $(call BuildPackage,nocatsplash))
diff --git a/net/nocatsplash/patches/openwrt-firewall.patch b/net/nocatsplash/patches/openwrt-firewall.patch
new file mode 100644 (file)
index 0000000..055b57f
--- /dev/null
@@ -0,0 +1,19 @@
+diff -urN NoCatSplash-0.92.old/libexec/iptables/initialize.fw NoCatSplash-0.92/libexec/iptables/initialize.fw
+--- NoCatSplash-0.92.old/libexec/iptables/initialize.fw        2002-12-27 11:44:41.000000000 +0100
++++ NoCatSplash-0.92/libexec/iptables/initialize.fw    2005-04-04 20:45:57.000000000 +0200
+@@ -28,13 +28,9 @@
+ # Load alllll the kernel modules we need.
+ #
+-rmmod ipchains > /dev/null 2>&1 # for RH 7.1 users.
+-for module in ip_tables ipt_REDIRECT ipt_MASQUERADE ipt_MARK ipt_REJECT  \
+-    ipt_TOS ipt_LOG iptable_mangle iptable_filter iptable_nat ip_nat_ftp \
+-    ip_conntrack ipt_mac ipt_state ipt_mark; do
+-
+-    modprobe $module
++for module in ipt_TOS ipt_mac; do
++    insmod $module
+ done