add dircproxy (closes: #1436, thanks to Martin Matuska)
authorNicolas Thill <nico@openwrt.org>
Sun, 1 Apr 2007 12:00:19 +0000 (12:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 1 Apr 2007 12:00:19 +0000 (12:00 +0000)
SVN-Revision: 6785

net/dircproxy/Makefile [new file with mode: 0644]

diff --git a/net/dircproxy/Makefile b/net/dircproxy/Makefile
new file mode 100644 (file)
index 0000000..74047d7
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2006,2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dircproxy
+PKG_VERSION:=1.2.0-beta2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz
+PKG_SOURCE_URL:=http://dircproxy.securiweb.net/pub/1.2/
+PKG_MD5SUM:=850443437f709276ff21a173bbf98456
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dircproxy
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=An IRC proxy server
+  URL:=http://dircproxy.securiweb.net/
+endef
+
+# uses Build/Configure/Default
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/dircproxy/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,dircproxy))