Add siproxd package
authorNicolas Thill <nico@openwrt.org>
Sat, 14 May 2005 20:32:03 +0000 (20:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 14 May 2005 20:32:03 +0000 (20:32 +0000)
SVN-Revision: 894

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/siproxd/Config.in [new file with mode: 0644]
openwrt/package/siproxd/Makefile [new file with mode: 0644]
openwrt/package/siproxd/files/siproxd.init [new file with mode: 0644]
openwrt/package/siproxd/ipkg/siproxd.conffiles [new file with mode: 0644]
openwrt/package/siproxd/ipkg/siproxd.control [new file with mode: 0644]

index ce1113fac0d6d7a4ef1a686ca92b7609149dc1a1..f42ceed1bfb2f34e079b24d7a48ec767db499e80 100644 (file)
@@ -62,6 +62,7 @@ source "package/fprobe/Config.in"
 source "package/maradns/Config.in"
 source "package/ttcp/Config.in"
 source "package/robocfg/Config.in"
+source "package/siproxd/Config.in"
 
 comment "Libraries"
 source "package/libpthread/Config.in"
index c081684559b40468a58165d3c66e2b7653e2acd8..0df4d1792aea1c5b54fbc8b413930c45a1025fa8 100644 (file)
@@ -84,6 +84,7 @@ package-$(BR2_PACKAGE_LIBPQ) += postgresql
 package-$(BR2_PACKAGE_LIBSASL2) += cyrus-sasl
 package-$(BR2_PACKAGE_LIBLTDL) += libtool
 package-$(BR2_PACKAGE_LIBOSIP2) += libosip2
+package-$(BR2_PACKAGE_SIPROXD) += siproxd
 
 DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd
 DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
@@ -129,6 +130,7 @@ tinc-compile: zlib-compile openssl-compile lzo-compile
 fprobe-compile: libpcap-compile
 cyrus-sasl-compile: openssl-compile
 openldap-compile: cyrus-sasl-compile openssl-compile
+siproxd-compile: libosip2-compile
 
 snort-compile: libnet-compile libpcap-compile pcre-compile
 ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
diff --git a/openwrt/package/siproxd/Config.in b/openwrt/package/siproxd/Config.in
new file mode 100644 (file)
index 0000000..9207a54
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_SIPROXD
+       tristate "siproxd - a SIP (Session Initiation Protocol) proxy"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBOSIP2
+       help
+         A SIP (Session Initiation Protocol) proxy
+         
+         http://siproxd.sourceforge.net/
+         
+         Depends: libosip2
+         
diff --git a/openwrt/package/siproxd/Makefile b/openwrt/package/siproxd/Makefile
new file mode 100644 (file)
index 0000000..035881a
--- /dev/null
@@ -0,0 +1,68 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=siproxd
+PKG_VERSION:=0.5.11
+PKG_RELEASE:=1
+PKG_MD5SUM:=a614f60683f9ea9423573bc5d646c525
+
+PKG_SOURCE_URL:=@SF/siproxd
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SIPROXD,siproxd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_SIPROXD):
+       install -d -m0755 $(IDIR_SIPROXD)/etc
+       cp -fpR $(PKG_INSTALL_DIR)/etc/siproxd.conf.example $(IDIR_SIPROXD)/etc/siproxd.conf
+       cp -fpR $(PKG_INSTALL_DIR)/etc/siproxd_passwd.cfg $(IDIR_SIPROXD)/etc/
+       install -d -m0755 $(IDIR_SIPROXD)/etc/init.d
+       install -m0755 files/siproxd.init $(IDIR_SIPROXD)/etc/init.d/siproxd
+       install -d -m0755 $(IDIR_SIPROXD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(IDIR_SIPROXD)/usr/sbin/
+       $(RSTRIP) $(IDIR_SIPROXD)
+       $(IPKG_BUILD) $(IDIR_SIPROXD) $(PACKAGE_DIR)
diff --git a/openwrt/package/siproxd/files/siproxd.init b/openwrt/package/siproxd/files/siproxd.init
new file mode 100644 (file)
index 0000000..f8739d4
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+BIN=siproxd
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  mkdir -p $RUN_D
+  $BIN $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+exit $?
diff --git a/openwrt/package/siproxd/ipkg/siproxd.conffiles b/openwrt/package/siproxd/ipkg/siproxd.conffiles
new file mode 100644 (file)
index 0000000..abb4ba5
--- /dev/null
@@ -0,0 +1,2 @@
+/etc/siproxd.conf
+/etc/siproxd_passwd.cfg
diff --git a/openwrt/package/siproxd/ipkg/siproxd.control b/openwrt/package/siproxd/ipkg/siproxd.control
new file mode 100644 (file)
index 0000000..d3b7b7c
--- /dev/null
@@ -0,0 +1,9 @@
+Package: siproxd
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/siproxd/
+Description: a SIP (Session Initiation Protocol) proxy
+Depends: libosip2, libpthread